Support

Open search

Can't switch from Wifi to Mobile data automatically

Highlighted
SOLVED
Explorer

(Samsung S9+)When i'm connected on Wifi everything works fine,but when i get out of range it switches to mobile data but no internet is available.I see that there is no ip address also.I have to swith to airplane mode on then off ,then the phone will conect on mobile data.Anyone else has or had this issue?It's annoying,i'm planning to return this phon if this issue is unsolvable.

62 REPLIES 62
Highlighted

For some reason this posted on teh S9 not the S10 area...

Retracted. 

Highlighted

I have been having the same problem since i updated to Android 9.0. When i leave my home, phone switches from wifi to mobile but unable to send or receive data. I go to connection settings and change the network type from LTE to 3g/2g then back to LTE again and it fixes the issue. Sometimes i don't use my phone for long time after i left home then realize i don't get any messages then i do the switching network type and all of a sudden missing messages, notifications, etc. pours like rain.

 

I have contacted my operator they say they get this complain from many customers who are all using the same specific models of Samsung.

 

What is more annoying and frustrating is that Samsung blind their eyes to this common problem and take no action. Shame!

 

Edit: My device is A8 (SM-A530F) with the latest security patch level October 2019

Highlighted

I have the exact same problem with my note 10+. 

Highlighted

I am having this issue on the brand new s20.

Highlighted

Till this day still not sure what the issue is...almost 3 years im using 2g/3g to avoid this issue.Not even the latest update solved this in 2020.Maybe its a provider issue maybe something else...3 times in the repair shop and 1 motherboard change.

Highlighted

I am having the same issue with my new S20+, I have been trying to figure out for 2 week what the issue is.

I noticed this morning if I change the Network mode to LTE/.... from 5G/LTE/... it solved the problem for now. But usually, the issue comes up again at a later time.

 

So again, the issue is as soon as I leave the house and the WIFI range is gone, the phone cannot find Bell network until I reboot it.

Highlighted
I am having the same issue with my new S20+, I have been trying to figure out for 2 week what the issue is.

I noticed this morning if I change the Network mode to LTE/.... from 5G/LTE/... it solved the problem for now. But usually, the issue comes up again at a later time.



So again, the issue is as soon as I leave the house and the WIFI range is gone, the phone cannot find Bell network until I reboot it.
Highlighted

I would suggest to take it back to the shop and get another phone...probably phones made in that serie were fauly.Mine was 3 times in the repair shop and once the motherboard was changed.Still have this issue but i use 2g/3g as a workaround.

Highlighted

Also someone reported that changing their carier solved the issue...havent tried this...

Highlighted

You have dual sim and by any chance do you use Telekom MK as a carier?

Top Liked Authors