Support

Open search

Can't switch from Wifi to Mobile data automatically

Highlighted
SOLVED
Explorer

(Samsung S9+)When i'm connected on Wifi everything works fine,but when i get out of range it switches to mobile data but no internet is available.I see that there is no ip address also.I have to swith to airplane mode on then off ,then the phone will conect on mobile data.Anyone else has or had this issue?It's annoying,i'm planning to return this phon if this issue is unsolvable.

61 REPLIES 61
Highlighted

For some disabling voLte helped,but in my menu voWiFi and voLTE are not available/missing.Hope Samsung Will sove this issue...

Highlighted

Here is a temporary solution that works.

 

Depending where you live some of the options for disabling or enabling voWiFi or voLTE might not be accessible.

Solution 1: disable voLTE and voWiFi 

Solution 2:(If settings not accesible)  Just use 2g/3g (Autoconnect) the problem is with the 4G.

 

Hope samsung will patch this issue.

View solution in original post

Highlighted

I have the same issue on my S9+ on Three (UK) network.

I will try the voWiFi or voLTE workarounds and report back.

Highlighted

I reproduced the issue again today by walking out of Wifi range to see I had 4G and no internet (not even an IP address).

Then I tried the same with voLTE turned OFF and it transitioned to 4G mobile data seamlessly.

Highlighted

A brief update. I was told by Samsung Support to try entering safe mode to see if the problem is caused by any 3rd party apps.

 

I re-enabled voLTE and entered safe mode as instructed. After having Wifi and walking out of range, again I see the 4G symbol appear, but I have no internet. IP (v4) address is not assigned and I have to disable and re-enable Mobile Data in order to gain access to the internet via Browser, Gmail, etc.

 

So apparently 3rd party apps are not at fault.

Highlighted

Not sure if i mentioned this,but going in safemode does not solve the issue.Just go to the aswer marked as solution on this post and you'll be fine,until there is an patch for this.My phone was in the repair shop and even changed the motherboard not knowing what caused the issue.

Highlighted

They're trying to get me to do the same thing and put it into the repair shop which I'm not happy about for such a new device. Its only 2 weeks old!

 

Interestingly I've just read from another forum that Three (my network) only support certain devices on their voLTE system and even then they have to be sold by Three. The S9 and S9+ isn't even listed yet (link below). On top of that mine was purchased SIM free from Carphone Warehouse (UK store) so this implies my device isn't guaranteed to work voLTE on my network anyway 😞

 

http://www.three.co.uk/Discover/network/4G-Supervoice

Highlighted

Just to update this thread, August Samsung patch has fixed this problem for me.

Great to hear @Gumpy321! Anyone else had any joy?

Highlighted

Even with the August update this issue still persists.VoLTE and VoWifi options are hidden still so i cant disable them.I only use 2g/3g autoconnect.Using 4g causes the problem.Without 4g this phone is useless.

Top Liked Authors