Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Wi-Fi Calling stopped working after February update

(Topic created on: 01/03/21 23:59)
Lestatou
Apprentice
Options
Galaxy S20 Series

My phone s20 galaxy did an update on February 25th and since then my wifi calling doesn't work. It's activated all looking good just my phone refuses to make wifi calls. I restarted it removed tge Sim, deactivated wifi calling reactivated ir, called my provider Tmobile USA everything works well on their side. I did a reset on the networks but problem still persists. My apartment has terrible signal and I have been relying on wifi calling. Since the 25th Feb 2021 all my calls going straight to voice-mail while I'm in the apartment. 

0 Likes
Reply
6 REPLIES 6
papashaun
Smooth Operator
Options
Galaxy S20 Series
Hi - there are quite a few posts on here about this with various suggestions If you do a search on the forum for WiFi Calling you should find a few of them
0 Likes
Reply
Lestatou
Apprentice
Options
Galaxy S20 Series

Thanks  for the info, I tried restarting the phone, removing the Sim, empty cache, reset network settings, updated my e911 address, spent 1h on the phone with Tmobile and everything is good on their side and pretty much everything else that the forums here suggested. Last wifi calling call I did was Feb 24th and Feb 25th phone was automatically updated and since then despite wifi calling being ON it doesn't work. I would like to reverse the latest update but I don't know how is that possible. 

0 Likes
Reply
Rich99
First Poster
Options
Galaxy S20 Series

I posted this on an older thread having sorted it yesterday, so may be of use?... I have placed a few bits extra [xxx] to give a bit more detail as I refer to the other thread which you may not have seen.

 

... the issue seems to be a combination of the phone gamely hanging onto any old signal on the mobile network even if not good enough to make a reliable call and some sort of incompatibility of VoLTE calling [part of 4G] and WiFi calling.

My Answer: I have installed the Samsung Band Selection app [from Google Play Store] to allow me to set WiFi calling as preferred [over the mobile network], but this didn't answer the issue as when there's even a whiff of 4G (and so VoLTE), this means WiFi calling won't come in (unless you reboot the phone every time you go to a poor signal). As this only really bugs me at home I have also set up a Bixby routine [search in Settings] to drop to 2G/3G only when connected to my home WiFi, so removing the 4G /[and so the] VoLTE incompatibility. Seems to work so far...

When at work with a solid 4G in-building and WiFi, ironically the poor implementation of WiFi calling helps out as it will still use 4G / VoLTE calling which would be preferred for reliability when the signal is decent. This answers the main 2 places I visit. If any more places came up on a regular basis like holiday accommodation, I could add them into Bixby as well. 

0 Likes
Reply
Lestatou
Apprentice
Options
Galaxy S20 Series

After I downloaded the App Samsung band selection that allows you to make calls using only wifi and deactivating cellular signal on my first call I was prompt with the message "connect to wifi to make a call" of course I was connected to a functioning Wifi at my house. I changed the band to 2.4 from 5 and still same message. I used friends wifi etc and still same message. Somehow my phone despite being connected on wifi and properly functioning internet when you attempt to make a call doesn't recognize that the phone is already connected to wifi. Any ideas?

0 Likes
Reply
nrngrng
First Poster
Options
Galaxy S20 Series

I have the same issue. Have you got a solution after all?

0 Likes
Reply
Lestatou
Apprentice
Options
Galaxy S20 Series

Unfortunately I didn't. Samsung encouraged me to take it to a Samsung repair center. Let me know if u get any solution please.:(

0 Likes
Reply