Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Samsung S20+ 5G SM-G986U1: Network Mode Doesn't Show 5G Option

(Topic created on: 11-08-2020 09:20 AM)
Murugesh
Student
Options
Galaxy S20 Series

IMG_1223.jpeg

 

IMG_1228.jpeg

 

Hi,

I bought an unlocked S20+ 5G USA version for test purposes. I inserted a test SIM and I don't see 5G option in network mode.

Shouldn't network mode should show 5g/4g/3g/2g even without inserting SIM? Some help here will be much appreciated.


Model SM-G986U1
Device Location: Santa Clara, California

 

Thanks.

0 Likes
20 REPLIES 20
iamS
Navigator
Options
Galaxy S20 Series
Hi @Murugesh. The problem is not the phone, but the SIM card you have inserted may not support 5G so the setting will not show on your phone until you insert a SIM card that is 5G capable. Hope that helps!
0 Likes
Anonymous User
Not applicable
Options
Galaxy S20 Series

you need a 5g plan and a 5g sim to use 5g

0 Likes
Murugesh
Student
Options
Galaxy S20 Series

The SIM I'm using is a Test SIM and it has 5G activated and about the Network we have our own Gnb. So, I'm sure it emits the required radio frequency.

0 Likes
Anonymous User
Not applicable
Options
Galaxy S20 Series

Are you using the device in europe with a european sim?

0 Likes
Murugesh
Student
Options
Galaxy S20 Series

No, this is an unlocked US Model and the SIM also belongs to USA.

0 Likes
Anonymous User
Not applicable
Options
Galaxy S20 Series

And are you using the device in america?

Otherwise i have no explanation for that

0 Likes
Murugesh
Student
Options
Galaxy S20 Series

Yes I am using it in US.

0 Likes
Anonymous User
Not applicable
Options
Galaxy S20 Series

try to go into settings, general settings, restore and then restore wireless settings, then turn off your phone. Press volume up and power to boot into recovery mode and from there perform the wipe cache partition.

In the end you will have to re register wifi devices ect... but you should solve.

Let me know. Also try to look for the setting with optimised or performance power mode, I do not know if it has an effect but it may be that medium power saving disables 5G modem (i know its nonsense but at this point it is worth a look)

0 Likes
Solution
Kamalsappal
First Poster
Options
Galaxy S20 Series

Try this. *#272*IMEI# 

Then click your network provider name. Then press install. Then press install sales and network. Phone will be restart. Check in network mode. There will be 5G option now.