Support

Open search

Notifications not working on mobile data

Highlighted
First Poster

Can anyone help???

 

Im not reciving notifications when on 4g,  yet when I go on WiFi, all of my notifications then pop up at once???

 

The best example of this is on WhatsApp. When I go onto the app the unread messages then show up (like it's just refreshed) but if someone calls me or messages me on WhatsApp I won't receive a notification unless I'm on the app? I've tried looking in the settings and everything seems to be enabled and I havent set anything to sleep or save data. Ive also tried restarting the phone. Ive just switched to the s20 5g from my old s9 and never had an issue on my s9.

29 REPLIES 29
Highlighted

Hi @jonmossman 

So sn update from me, I've got a 3rd S20+ and still seem to be having issue, also with my S7, so last chance saloon is removing an adult content block thats on by default... see below for message to another poster.

 

'

THB when I called Samsung they offered me the replacement no problems, didn't need to wait for them to inspect my old device so don't know either way.

 

So I've just been to the Three store and had the adult block removed. They did tell me I still had to call up to get a 4 digit pin to then use when prompted when I browsed an 'adult' site. Called up, got to the correct department via automated press 1 for....etc....and recorded message told me the lock was removed, no need for the pin it seemed. Googled a rudey site and it fired straight up, full on boobies lol. Gave handset a reboot for good measure.

 

Next step for me was to check for notifications, which seem to be coming....being a footy day I get quite a few from Twitter and they're coming in. Now a way I've found to get a quick notification is using Ebay and watching an item with just over 15mins left. Ive set quite a few, these were notorious for never coming through unless on wifi YouTube also, and all have worked.....

So for now alls well. Ill give you a shout in a day or 2 with an update but at the moment its a positive, but I've felt like this before lol.'

Highlighted

Hi all @jonmossman @dmsmith96 @Jook @Libb @BandOfBrothers 

 

So I seem to have my issue sorted....

 

Just an update after the weekend.....

 

Not had a problem at all, everythings seemed to come through fine. Waited all day to turn on wifi and no surprises when it connected.

Just had a day at work with notifications coming through all day. Just turned wifi on  at home and there's nothing extra that's been missed.

 

I'm going to now have to put it down to the adult content block on the Three network. Must of been conflicting somehow. Not sure if your on the same network but even if not, check if they have a content block on cuz its defo worked for me.

 

Hope you all get sorted :winking-face:

Highlighted
First Poster

Hi all, chiming in with the same issue, also on Three. 

 

It's definitely not a handset issue. I've just upgraded to an S20 from an S8 and both have the issue. It only started happening a month or so ago on my S8. I can't give an exact time as I've been working from home so on WiFi most of the day. Just when I do go out I usually come back to 5 or so notifications from a range of different apps including messenger, WhatsApp, emails, social apps, etc.

 

Very annoying! I've been with Three over 8 years and never had this issue. I don't really wanna change network as I have unlimited data. Has anyone had luck debugging with Three? 

Highlighted

I've turned off the adult filter on the s20 plus which does seem to have helped from what I can tell. Would be worth yourself and reporting back here? Good luck trying to get through to anyone at three! 

Highlighted

@Jook wrote:

I've turned off the adult filter on the s20 plus which does seem to have helped from what I can tell. Would be worth yourself and reporting back here? Good luck trying to get through to anyone at three! 


Are you talking about the adult filter on the Three account itself or am I missing a setting on the phone? I just checked and as far as I know, my adult filter has been off for 5 or so years already. I resubmitted my preferences via the app anyway to see if anything changes.

 

Funnily enough I didn't get an email notification you'd replied until I connected to wifi 😕

Highlighted

Yes via the app on your phone. I think it is phone specific on the settings rather than sim card number specific. I might be wrong on that though. 

Highlighted

Okay well as I say, I've resumitted those preferences so we'll see. I'm popping out later so will be able to test then - thanks.

 

Thinking of other networks if Three can't sort this out - I wonder if Smarty would have the same issue since they use Three's masts

Highlighted

Hi @AdaaamB 

 

I can only reiterate what @Jook has mentioned and have the adult content unlocked. Soon as I did it helped, must be some kind of conflict fighting with the notifications.

 

Hope it helps 

Highlighted

Smarty has the issues too - I've just switched from Three which was fine but am now not recieving any notifications with wifi turned off. I have also turned off the adult content lock online but adult content is still blocked.

Highlighted
New Member

Worked for me too. Turned off adult filter and I'm now reliably getting all whatapps when on mobile data. 

 

Cheers guys

Top Liked Authors