Support

Open search

Mobile Data is switched automatically upon SIM 2 enable

Highlighted
Apprentice

Hi dear community.

About a week ago I've moved from Pixel 2 to galaxy s10e and I'm really enjoing my new phone except the situation I about to describe here.

I have 2 SIM cards inserted : my local and Google Fi, which I'm using for travels, so this card it turned off most of the time (all of the time during last week).

 

So, the problem is that my local card mobile data can be turned off unexpectedly in random moment of time. When mobile data is disconnected, I'm going to SIM card manager and observe, that mobile data is used on SIM 2 (Google Fi), which is disabled. To fix that, I need to swich it back to my local card. It happens ~2 times a day.

 

Another strange thing that might be related is when I'm enabling SIM 2 (Google Fi) card, my mobile data is automatically switched to SIM2, while Calls and SMS are left on SIM1. I've shoot a gif to show how it looks like: https://i.imgur.com/svaUR3O.gifv

 

So, my assumption is next: phone having SIM 1 enabled and SIM 2 disabled sometimes `pinging` SIM 2 to check whether it works or not. During that proccess, it toggling SIM 2 enable status, which leads to mobile data being switched to SIM 2 and turned off.

 

My os version (One UI 2.0) : G970FXXS3BSL4/G970FOXM3BSKO/G970FXXS3BSL4

  • OS

12 REPLIES 12
Highlighted
Apprentice

Anyone?

Highlighted

I have similar problems w S20 ultra.   TELEKOM eSIM and Google Fi in Sim 2.   Always wants to change to Sim 2 when i leave my house.

Highlighted

Finaly I've got someone that experiencing the same!

I described this problem to Samsung Support few months ago with link to this topic provided, and here what they answered:

Your Adaptive-Wifi might have been enabled on your settings without noticing it. Most mobile smartphone nowadays has a Adaptive Wi-fi or Intelligent Wi-fi feature which allows the phone to switch to mobile data connection automatically once it detects that there isn't sufficient enough download speed from current Wi-fi connection. This is to avoid disrupting of data connection when a user is connected while media streaming or downloading a certain content.
 
You can easily change this by:
 
1. From the home screen, swipe either up or down to access apps.
2. Select Settings.
3. Select Connections
4. Tap Wi-fi
5. Tap More options (3 dots on top right)
6. Select Advanced
7. Tick to disable Adaptive/Intelligent Wi-fi
 
Additionally, you may also uncheck/disable 'Mobile data  always active' under developer options'
 
To enable developer options,
 
1.        From the home screen swipe down to access settings.
2.        Tap the settings icon.
3.        Tap About phone.
4.        Tap Software information.
5.        Tap seven times on Build number.
 
Once Enabled, go back to Settings again and this options has been added at the bottom menu.
 
Open the Developer options and disable 'Mobile data always active' option. You can also disable 'Auto-update apps upon restart' from this page.
 
We hope to hear from you again soon.

But it looks like they've understood my problem incorrectly, so I just started to passively wait to get this fixed by updates.

Highlighted

Thanks for sharing, but yes, they seem to have midunderstood!   Neither of those options were enabled on my phone.

 

My problem does seem to be related to leaving my home WIFI and switching to mobile data.  It seems to sometimes/unpredictably, decide to change to the SIM2 data instead of the pre-set (and local priced) eSIM data network.    Frustrating....

Highlighted

Thanks, @cr-hamburg 

Same situation, but with 2 physical SIM cards.

Waiting for some one from Samsung to pay attention on this problem ...

Highlighted

I had an idea for a work around to avoid data fees.  I have changed my FI SIM to only working on 2G.   That way I can still get calls and texts, but this should at least mean that if the phone flips to that SIM for data, I will notice the speed change and won't use much data!!!

Highlighted
First Poster

Same problem since half a year. Very annoying. Main card is Vodafone, secondary card is Google fi. Have tried replacing the Vodafone card. Have tried upgrading from Samsung s10 to s20. Still same problem. Only thing I didn't try is replacing the Google card.

 

My phone will switch data from main to secondary card every now and then. But keep voice and sms on primary card. My fix is to disable data in the Google fi app. But it's really messy to have to switch sim card in the settings several times per day... 

Highlighted
New Member

Same very annoying problem, I also have Google Fi sim as a secondary. This start happening to me few weeks ago just after a software update on my A70.

 

perhaps the most shocking thing is that so many people are experiencing the same problem and samsung doesn't seem even bother to try and fix the issue. Or maybe is just google making us use there service instead?

 

Just going to say that if this was happening on an iPhone, one will be able at list to talk with the support team.

Highlighted
Observer

I'm having the exact same issue, and it's so frustrating. SIM1 is Google Fi, and SIM2 is AT&T. The phone keeps switching data back from SIM2 to SIM1. I noticed this issue started several months ago after a software update. 

Top Liked Authors