Support

Open search

Cannot disable smart lock

Apprentice

I want to disable smart lock on my s10e, but I cannot. I have no connected devices set up, I have on-body detection turned off, and I have my one trusted place turned off. Yet, when I'm home, the phone shows 'Phone unlocked by Smart Lock'. 

I cannot remove my Trusted Places. There's no option to do that. It's either turn it on or off. 

I don't want Smart Lock enabled but I just can't get rid of it!!!

3 REPLIES 3
Back for More
The only way I know to disable this is, go to Settings > Lock screen > Secure lock settings (you will be asked to enter your unlock code) and then enable the Show lockdown option. This will put another option on the power off screen to completely lock your phone until you enter your preferred unlock method.
Navigator
while in trusted places press and hold till the option to turn off this location appears you can turn it off or on
Apprentice

Turns out that my Bixby Routine to leave the phone unlocked while I'm on my home wifi is the 'culprit'. This hooks into Smart Lock and leaves the phone unlocked. But seriously, Samsung, how the f*** are we supposed to know this? You couldn't say so in the description of the 'keep phone unlocked' function when i set up the Bixby Routine?? It's not intuitive in the least to think that Bixby Routines have anything to do with Smart Lock, because one is Samsung and the other is Google.

As for the 'Trusted Places', turns out Google does this automatically if you have a place labeled as 'Home' in Google Maps. I never added the trusted place to Smart Lock, Google did.

 

Top Liked Authors