Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

S10 Plus ignores Wifi Preferred setting - SM-G975F

(Topic created on: 03-06-2019 01:20 AM)
JamesGlenn
First Poster
Options
Galaxy S10 Series

I have the international version of the S10 Plus working well here in North America on T-Mobile except for a few minor bugs. The most annoying of those is the behavior of Wifi Calling.


Although Wifi Calling does work quite well, I have to put the phone in Airplane Mode and enable wifi to force it into Wifi Calling mode. I set the SIM to "Wifi Preferred", which should automatically switch to wifi when I'm on my wifi network. At first, it would switch to wifi calling when it first connected to my wireless router then would revert back to the mobile network after a few minutes. However, since the April 1 update, it completely ignores the "Wifi Preferred" setting behaves as if "Mobile Network Preferred" was selected.


As long as I remain in Airplane Mode with wifi enabled, it keeps a steady connection to Wifi Calling. The moment I enable the mobile network it switches back.


Has anyone else experienced this issue and, if so, how do I get this to abide by the Wifi Preferred setting?


3 REPLIES 3
doesitmatter
Voyager
Options
Galaxy S10 Series
I have the international S10+ (G975F/DS) here in the states using T-Mobile as well and my Wifi calling is working just fine.

On your lock screen at the top do you see the scroll saying T-Moble Wifi Calling? On your phone app there should be a Wifi symbol on the button. Samsung doesn't make it easy to see if you're on Wifi calling or not, they've hidden it for some reason like it's a big secret.

If you don't, try doing a network reset on the sim card to see if that helps. When was the last time you got a new sim card from T-Mobile? They do go bad sometimes.
0 Likes
roastedwookie
Pathfinder
Options
Galaxy S10 Series

At least you have the setting for Wifi-preferred. I do not see that option in Settings. I can only enable/disable wifi calling. Exynos model.

Idontwannatellyou
First Poster
Options
Galaxy S10 Series

I have the same problem on my s10e.  Cellular coverage inside my home is bad so I need WiFi calling.  It was working great until a very recent update now I keep getting bounced to Cellular preferred when I am inside my house with strong wifi signal.  I set it back to Wifi preferred but a few minutes later the phone alerts me that it switched to Celluar preferred.  LOSING my mind with this.  

0 Likes