Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Samsung Galaxy A53 can't connect to mesh wifi (TP-Link Deco X60)

(Topic created on: 05-09-2022 07:40 PM)
Akuher
Journeyman
Options

Samsung Galaxy A53 is not able to connect to TP-Link Deco X60 mesh wifi. Connecting to the wifi fails most of the time and when it finally succeeds it soon disconnects again. I have tried resetting Galaxy A53 network settings and even hard resetting the phone. Those measures didn't solve the problem. I also got a replacement phone but still the same problem occurs. We have two other Samsung phones and multiple other devices connected to the same mesh wifi without any problems. Galaxy A53 is the only one that fails to connect.

I have tried to solve this problem with TP-Link and they have acknowledged the problem. Unfortunately, they haven't been able to fix it and now they are leaning towards this being Samsung's problem, not theirs. Maybe a problem with latest Exynos chips. You can also find discussion about the problem here:

New Samsung A53 can't connect stable to Wifi on Deco X60, connection keeps dropping - Home Network C...

It seems that the problem is with 5 GHz wifi with safety encrypion enabled. If any kind of safety encryption is enabled on the wifi when 5 GHz is also enabled, A53 is not able to connect to it. As soon as I disable safety encryption, connection becomes stable. Also disabling 5 GHz removes the problem. Sadly, neither of these are a permanent solution to the problem. I also noticed that A53 is able to connect to the mesh wifi's main router. Wifi connection is stable near the main Deco but connection fails as soon as A53 moves nearer one of the two slave Decos.

I really hope Samsung can fix this soon! A few weeks ago I posted about this problem to the US Samsung Community but for some reason that post got deleted without any answer from Samsung. I know this is a wide spread problem as you can see from the TP-Link forum discussion (the link above). Hopefully Samsung isn't trying to wipe this under the rug.

Galaxy A53 5G 

37 REPLIES 37
Akuher
Journeyman
Options

I ended up buying S23+ and left A53 as a spare phone. At least my S23+ has worked flawlessly with Deco X60. No problems at all with wifi.

MCK168
Journeyman
Options

I went to Samsung Repair center and let them check.  Finally, they reported to me replaced the mainboard and some IC.  Now, the phone with stable Wi-Fi 5Ghz.  But the speed still cannot got the maximum speed (263 - 390Mbps).

0 Likes
mobiker64
Explorer
Options

Sounds good. Great, that Samsung find a solution for you. I guess, you have another WiFi-chip on your new, replaced mainboard. It is a mess, that Samsung is not able to deliver a working WiFi-driver for the A5 😞

0 Likes
asadulhuq
First Poster
Options

I get the same problem here with M50. The Samsung service says that they need to change the motherboard to solve the wifi problem. I can't rely on that, so I did regret.

0 Likes
Ddlc
First Poster
Options

I have the exact same behaviour on my A53 5G. Continuous connection dropping. Other 40 clients do not experience any issues at all on my X60 mesh. Could you please indicate me how to proceed in order to have the telephone repaired?

0 Likes
MCK168
Journeyman
Options

Last time, I just went to Samsung Service Center and let them knew this issue.  The customer service connect my A53 to their WiFi.  He saw the WiFi speed not stable and dropping.  Finally, he wrote down this issue to the engineer.  After three day, they SMS to me to getting back my phone.  You can try if the waranty not exprie.

mfrater
First Poster
Options

Does anyone from Samsung actually read this forum? Come on Samsung! Do something about this issue. The people here have been waiting for about a year for you to fix this issue. And they probably represent less than 1% of the people affected by it.

0 Likes
Ddlc
First Poster
Options

Hi. In my case, resetting the network settings has eliminated that same behaviour. Drawback is you lose the saved wlan passwords and Bluetooth connections, but this would have been (and much worse) the consequence of having has the device serviced by the technician at samsung. 

0 Likes
mobiker64
Explorer
Options

Dear mfrater

I guess, Samsung is not working on solving this issue. Every A53-owner has to find a own solution. Some owners got back their A53 and bought another device. Some owners get this issue solved by Samsung when Samsung replaced the mainboard of the A53-device. From my end, I do not have any hope anymore, that this issue will be fixed in the future.

Ddlc
First Poster
Options

Have you tried applying a reset to the network settings in the A53? It has definitely worked for me. 

0 Likes