Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Airpods Pro connectivity issue with Samsung A51.

(Topic created on: 23-05-2021 05:06 PM)
srpetkar
First Poster
Options
Galaxy A Series

Hello, 

I'm facing an issue with Samsung Galaxy A51 while connecting Airpods Pro with it. 

Does anyone knows how to fix this issue ?

Note My Airpods used to perfectly work with Note 9, S series, Nokia Android One series etc.

But while playing music, youtube, movies there is a lag. 

Note: I'm able to easliy make or recieve a phone call via airpods.

Thank you,

Sajjad Petkar

2 REPLIES 2
skandigraun
Explorer
Options
Galaxy A Series

Well... generally there are two settings you can try changing when "fixing" Bluetooth, but both of them are just blind shots.

Anyway... enable Developer mode on your phone (Settings/About Phone/Software Information menu, tap 7 times on Build number). A new option called "Developer options" will be available at the bottom of Settings menu.

In this menu you can try 2 things:

1. Look for "Bluetooth Audio Codec", and change it. The Airpods Pro supports SBC and AAC (anyway, you can only select options that are supported by the currently connected headset, you can't go wrong). Once you changed it, check if you still have a lag.

2. Look for "Enable Gabeldorsche" option, and toggle it. This is the name of the new Bluetooth stack of Android, rewritten from scratch. Currently not enabled by default, and the old Bluetooth implementation is used, but you might want to give it a try, it might fix your issue.

 

0 Likes
srpetkar
First Poster
Options
Galaxy A Series

Thank you so much for your reply.

I did tried this but didn't work 😕

 

0 Likes