Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

a70 wifi turned off when screen is off

(Topic created on: 18/07/20 13:59)
arbata10
First Poster
Options
Galaxy A Series

why wifi turning off when screen is locked, i have android 10. Firmware reinstalled in service, i did two times reset, one lucky, next still same problem ,wifi goes off when screen is off, battery saver is off. one lucky time i did reset and not goes to off when screen is off, next time i did reset, and still same happens life before , not turned saver battery. where problem? in a5 2017 i know was be wifi sleep policy and i see three options in wifi settings (keep wifi when screen off,not keep when off , keep when charging), and i enabled battery saver and i set to wifi sleep never in a5 2017, so battery saver is not issue like was in a70

maybe this turn off wifi when i enabled first time power medium battery saver? and turned off , when i did reset not turned on battery saver , and wifi not turned off when screen is Lockedwhen i enabled power medium saver battery problem started again, i do reset hard , nothing changed, so reset did not fix. i never turned on battery saver from last reset time. 
 still DISCONNECTED WIFI WHEN SCREEN IS OFF, AND random turned on again for random hours interal i use in home 4g gps offwifi auto turn on when he knows nearby router name turned off this feature, still turning on itself when i go to outside, and i dont press wifi toogle. 4g i left 5 hours to on to see dissconnected like wifi . so 4g not disconnected when screen is off, only wifi dissconnected when screen is off, in my n8 and n9 not have this problem when i enabled power saver mode in n8 n9 still have wifi when scree is OFF with BATTERY SAVER OPTION AND NOT disconnected.  so where is problem? my s9 back cover water drops had 
 when was rainy day my phone back cover very wet....

0 Likes
Reply
6 REPLIES 6
db91
First Poster
Options
Galaxy A Series

Hi I'm having exactly the same issue I think the issue has come from the last update I did to the phone. I hope someone at samsung can look into this I tried resetting network settings and this didn't help. Its very intermittent. It's got worse over the last week. I did contact samsung help support but they couldn't suggest more than doing a full reset which clearly as you said didn't help. Will be keeping an eye on this post. 

0 Likes
Reply
arbata10
First Poster
Options
Galaxy A Series

so you said the same issue by latest update? i updated to android 10 latest security patch which is april 1 , i installed three  updates security patch from android 9 to android 10 security patch April 1 , i had two updates after i updated to android 10 from 9 . Android 10 security patch going to April 1 , so maybe had Android 10 security patch mmm example (January,February,March and after that i installed latest security patch but not android 10 :face-with-tears-of-joy: because i installed first android 10 from 9 , and i installed three times security patch because notifications shows installed updates, because the tab its not turn off in lockscreen and notification panel i hate that, so i installed all updates.  

0 Likes
Reply
Rubblebuster
First Poster
Options
Galaxy A Series

Hi all,

 

did you guys find a solution for this issue? Because after updating to Android 10 in September I have the same problem again (after it seems to have been fixed with one of the previous security updates)... 😞

 

That's a really annoying issue. In case I want to use WhatsApp Web I always have to search my phone and switch on the display so Wifi gets enabled... 😞

0 Likes
Reply
Guardian2142
First Poster
Options
Galaxy A Series

I have this issue as well, after my phone is in sleep mode, my wifi dies. even if I unlock the phone i have to turn off the wifi and turn it on again for it to work! this is annoying as hell and it bugs the hell out of me. WHAT IS THE SOLUTION SAMSUNG

0 Likes
Reply
DavidAid
First Poster
Options
Galaxy A Series

Hello! I don't know if you still have the problem or the phone, but I found a solution that finally works :smiling-face:

You have to activate developer options (by pressing on your Build number until its activated), then you want to scroll down to Network and disable Wi-Fi scan throttling. This seemed to be what causes the Wi-Fi to turn off, as it allows your apps to scan the network only once every 30 minutes, thus thats why it disconnects.

Hopefully this helps! I was looking for a solution for a very long time, so I'm happy I finally found it.

arbata10
First Poster
Options
Galaxy A Series

no its not fault developer options, still disconnecting when i off wifi throttling. when i did reset and not turn on power save mode wifi dont go off when screen is off. when i enabled battery saver mode its disconnecting when screen is off. note 8 with power saver mode dont turn off wifi when screen is locked. a70 loose wifi when screen is off with battery saver and without. 

0 Likes
Reply