Open search

(SOLVED)Nagging Bluetooth problem with Gear S3 Frontier.

First Poster

Hi everyone. 
Just registered here, mainly due to an issue with my Gear Frontier.
Firstly, I have an Android phone, but don't use it as such, I just use it with the S3 Frontier. The phone I use does not as yet support wearables.
The issue with the Frontier is that it is constantly nagging me to "Connect to phone via Bluetooth." As far as I'm aware I have turned off everything to do with sharing data with the phone. I have turned everything off on the Frontier also.

But every 10-15 minutes I get the "Connect to phone via Bluetooth" message, even when I turn off "Bluetooth disconnection alerts" in settings.
I have tried everything I can think of, including resetting the watch to factory settings (this fixed it for about 2 weeks), but it suddenly began nagging me again.
I have a few ideas what's causing it but I'm open to other suggestions from the community.

First Poster

I know this post is already a while ago, but why cant people when its suppsedly solved, also post what they did to solve it, so others can benefit from it ?


How was this issue solved ? Because I do have the same issue.

First Poster

I have the same issue here. I tried many ways to reconnect my watch and my Huawei P9 Plus but it kept saying unable to connect to my phone. Many posts saying toreset the watch and app which I did everytime when it disconnected. However the disconnect has been more and more frequent. Now it disconnects few times a day and I can't keep reseting my watch and deleting and installing the app everytime. It is very annoying! Can anyone help? or do I go back to the store and exchange another one?

First Poster

Connecting at all isnt the problem for me, it just disconnects too often. Even if there is not much distance between the watch and the phone. Even if its right next to it.


I did everything I can come up with so far. I thought it might be a problem with non-Samsung phones, but I also read many many posts about users even with Samsung phones, so it cant be that. I have not found any reliable solution which seems to fix this problem, other than returning the watch. But its not like there are so many other Smartwatches for Android with as good features that are any better really. While i was using an iPhone with the Apple Watch, I never once had these issues. I'd say Smartwatches with Android still aren there yet, as far as reliability with connection. I mean, the new phone i have (Mate 20 X) even has Bluetooth 5.0, as opposed to my previous iphone 6S plus, which only had Bluetooth 4. So technically there should be a better and farther connecction possible, and yet its not.

Did I do a mistake by going back to Android ???

First Poster

I don't think it is your problem Wolfseye. Samsung should have foreseen this issue when they were doing R&D as they can't just expect user only use certain brand of smartphone to connect to their smartwatch. If it is so, I will throw my Gear S3 into bin now. I have been searching the old posts but there is no certain solution to fix it. I really don't understand how those people overcome this issue or they just don't mind to reset their watch over and over again.

First Poster

I don't know who marked it as "Solved", but it's still a PIA for me.

The latest update a week ago hasn't fixed the issue as yet.

First Poster

This is my main beef with tech companys. There's only two mobile OS developers out there....... WRONG!!

My phone of choice is a Sony XperiaX, but it's not Android. It's been reflashed with SailfishX OS, which is a development of Jolla (Ex-Nokia R&D team). When Nokia were "PUSHED" into oblivion by Microsoft the MeeGo R&D team broke away and took the MeeGo OS with them, where they reworked it to Sailfish OS, which can run Android apps via an Alien Dalvik installation. The Galaxy Wearables app will install but doesn't run too well because it insists on using Google Play Services, which is the backstop. Jolla have indicated that they are working to bring wearables support to Silfish OS, so I'm prepared to wait for then rather than sell my soul to Google.

First Poster

Hey guys, weird thing happened to me. After 2 days of posting my comment here, when I was rebooting my watch, uninstalling and installing in my phone for the reconnection, I was advised to install an app name "Sumsung Accessory Service". My watch used to lost connection with my phone about 2 times a day but after installing the app I have not had lost connection since then.

First Poster

Maybe you had a corrupt file and reinstalling and reconnecting the watch reinstalled the file.


I have the same problem with my iPhone 8. The watch is disconnected very fast/ often, and most of the times I have to really build up the connection again by means of starting the Galaxy watch app (and waiting for reconnection). Sometimes this wont even work, and I really have to remove the watch and pair it again. Any tips?

Top Liked Authors