Support

Open search

Contacts in secure folder is not up to date

Apprentice

I use my Google account to save my contacts.

 

And I´m using google account in several gadgets like desktop pc, laptop, mibile phones, etc.

 

I´ve installed this account on secure folder too, but I have to manually do the sincronization.

 

The other contacts are always up to date.

 

When I save a contact in one gadget, all of the ar up to date, except for my "secure folder". I have always to syncronize it before using whatsapp or to make a call to a new contact.

 

Is there any solution?

8 REPLIES 8
Superuser I
Superuser I

It could be that the Secure Folder is intentionally gated off so nothing can access it.

 

This could mean the updating process too. 

Current Phone ~

Samsung Note 9 Model: SM-N960 Dual Hybrid 512Gb_ Samsung One Ui / Pie.

Samsung Gear s3 Frontier Watch
Samsung Galaxy Tab A {2016}SM-T580

Apprentice

Maybe you´re right, but I still think it´s  a bug.

 

First time I tried to use my google account on secure folder, i had a message: "This account is already in use".


So, I couldn´t use the same account inside and outside secure folder. They aren´t gated off at all.

 

I called Samsung Concierge and they said to uninstal contacts from secure folder an it didn´t work. liek we wanted

 

Then, they said to uninstal secure folder.

 

I did that and put the secure folder again, and the contacts inside secure folder again.

 

Ok!

 

After a full reinstallation of secure folder and contacts, I can use the same google account inside and outside.

 

They should be independent now, or gated off like you said.

 

Today, I´ve entered secure folder and tried to syncronize my contacts from gmail and it´s not working....

 

I did the same thing yesterday and it worked.

 

It apeears to be an intermitent bug.

 

And if it is a bug, Samsung must must fix ASAP, don´t you agree?

Observer

I faced the same issue. My google contacts were not updating in the secure folder, as a result, the Whatsapp I used in the secure folder could not add certain chats with certain contacts.

 

You have to go to Secure folder --> Click the 3 dotted icon at the top right of screen --> Settings --> Accounts --> Enable Auto Sync.

 

That was it. My auto sync was disabled which prevented my google contacts accunt to sync.

 

Hope this helps.

 

A

New Member

On my S7 edge Secure Folder is connected (or is a part of) My Knox. So I had to open My Knox settings, Share data and enable the option IMPORT TO MY KNOX: Contacts (from Personal) and that solved the problem.

New Member

I have similar Sort of Problem with my Galaxy S8, Everytime i try to sync or import my contacts From GMAIL in Secure Folder Contacts Tab its says Failed to import. i even tried Importing Contacts From .VCF file & it said same, failed to import contacts.

On top of that sync with Accounts Doesn't Work at all only in Secure folder, i tried adding my Work gmail (another gamil) Account & first time it was accepted but contacts were not sync or imported to secure folder and after that everytime i tried adding my account it says account already exists on this device. Actually i am trying to Create a Seperate account for my workplace Only in a secure folder and it's Not Working.  The main function of Secure folder is that you can Create a seperate Profile Or account parallel to your personal Account,but it is not working in My Samsung Galaxy S8.

In short Sync or importing Contacts from gmail doesn't work in secure folder (samsung knox secured).

Kindly help me out to Solve this problem if anybody knows how to or is there anything i could do to solve this Problem please tell me.

Thank You. 

New Member

I have the same issue and then i try 1 comment on top of mine

 

Just go to secure folder setting on 3 dot on top right corner then choose account then try to click enable autosync on 3 dot on top right corner. Tadaaaaaa....is all good.

Apprentice

When I made contact with Samsung concierge, they tried to uninstall and install contacts and it starts to work... but.. few months later, the problem reapears..

 

And when we were trying to solve, I did this 3 dot thing.

 

Sometimes contacts works and sync, sometimes don´t.

 

Same occurs to secure locals.

New Member

*******Solution*******

For everyone who have the same issue just follow my instuction below your issue will be solve.

The reason that Secure Folder cannot sync google contact/google calendar is it is missing "Google Contacts Sync","Google Calendar Sync" or THESE APPLICATION ARE NOT GRANT FOR REQUIRED PERMISSON.
1. Go to Setting under Secure Folder

2. Apps

3. 3 Dots > "Show system apps"

4. Find "Google Contacts Sync"

5. Permission

6. Turn on "Contacts"

7. Do the same for "Google Calendar Sync" (Sure permission is "Calendar" not "Contacts")

8. Back to first page of setting

9. Accounts

10. Turn off Auto Sync

11. Turn on Auto Sync

Top Liked Authors