Support

Open search

how to delete an unsaved number from your call log

SOLVED
First Poster

how do i delete an unsaved number from my call log so with I put the digits in it does not show up again. please help asap using a Samsung galaxy s8 plus

2 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

Hey, if you haven't found a solution yet this is what you do. Actually i had the same problem n looked it up n this samsung link came first. I tried all those methods too recommended in the chat by these people but it didn't work. The solution is, open phone, go to recent calls then click the dot that are on the right hand top corner, den to the option which says (show messages) den click n hold on one of the numbers shown den there will be an option of left hand top corner, which when u press it would select all of the numbers den when u have done that den press delete. N remember this won't delete ur messages dis will only delete the unsaved numbers. It worked for me, i have a s8+. Hope this works for you too. 

First Poster
I had the same problem as you..I also had to go under call log backup/restore, contacts, contact storage and all the phone icons and deleted the data/cache for all of them and this fixed by problem
7 REPLIES 7
Superuser I
Superuser I

@nakita

 

First of all delete the number from your call log by pressing and holding the number and you'll get the option to delete it.

 

Then go into your Settings > Apps and then click the 3 little dots in the top right hand corner and select 'Show system apps' and scroll down to 'phone' (you know the little green phone app icon) and go into it and scroll down and select 'storage' and in there clear the data and cashe and that'll clear the number from the phone's memory. If there's more than 1 call icon, like mine, go into them all and do the above.

New Member

@John4Ohwrote:

@nakita

 

First of all delete the number from your call log by pressing and holding the number and you'll get the option to delete it.

 

Then go into your Settings > Apps and then click the 3 little dots in the top right hand corner and select 'Show system apps' and scroll down to 'phone' (you know the little green phone app icon) and go into it and scroll down and select 'storage' and in there clear the data and cashe and that'll clear the number from the phone's memory. If there's more than 1 call icon, like mine, go into them all and do the above.


Hi, I tried this method will all three 'phone' icons that appear in my phone (galaxy s8/ android 8.0) and the deleted number is still showing up. Is there anything further I need to do to permanently remove this number? 

New Member

Hey, if you haven't found a solution yet this is what you do. Actually i had the same problem n looked it up n this samsung link came first. I tried all those methods too recommended in the chat by these people but it didn't work. The solution is, open phone, go to recent calls then click the dot that are on the right hand top corner, den to the option which says (show messages) den click n hold on one of the numbers shown den there will be an option of left hand top corner, which when u press it would select all of the numbers den when u have done that den press delete. N remember this won't delete ur messages dis will only delete the unsaved numbers. It worked for me, i have a s8+. Hope this works for you too. 

First Poster
I had the same problem as you..I also had to go under call log backup/restore, contacts, contact storage and all the phone icons and deleted the data/cache for all of them and this fixed by problem
New Member
Worked for me, SFM. 😁
So much easier than having to unhide system apps and deleting the cache that way.
First Poster

Best way to worked fine even on Samsung s10

First Poster

Zain which method you use to solve this problem.I have galaxy s9 and version is one ui.i tried all these methods but could nit solve thia issue

Top Liked Authors