Support

Open search

S8 smart lock - trusted location issue

First Poster

I've used my S8+ for 18 months and love everything about the S8+ except for TWO complaints. My first complaint is Sprint sales related.  When I signed up for the S8+ promo (lease one,  get the second free), I inquired about Sprint/Samsung offering/creating a Note 8 device (I owned, used and love my Note 3), and the Sprint sales rep assured me that Samsung would not be releasing a Note 8 version (citing the S7 Note debacle as the reason). Three months and a few days later, Sprint started advertising the S8 Note. Yes,  I  was extremely upset,  but after using my S8+ for Three months,  I was not keen to transferring my data again on our two phones, plus I was not looking forward to the ugly dialogue from Sprint's sales and support people.  

 

My second huge issue with the S8+ surrounds the device's extreme lock screen. I researched, tested and tried many lock screen settings,  but nothing worked as described.  Almost every time I tried unlocking my device I  would spend an inadorant amount of time sliding screens, entering my pin, then waiting... just to be looped back. I had to start over, sometimes many times.

 

Sadly. I'd I turned off lock screen many of my financial apps would not open due to lack of proper lock screen security. Ugh.

 

I tried the smart lock using approved devices,  setting my location,  on body detection,  but nothing worked.  I did see my device's location was incorrect on google maps, and tried many attempts to trouble shoot the issue. I checked my home settings throughout all of my google apps and products, those needing my home location,  but I never thought that the cause of the incorrect device map location would be the actual Samsung S8+ device. 

 

I consider myself fairly sharp,  helping many friends and family members with all tech related problems,  but besides my embarrassment, now I'm seriously pi**ed off at Samsung (and Sprint).  I only stay with Sprint because of my prior employment and retirement (my last project involved helping to launch 3G), but as a former employee I  receive few phone service benefits. In fact, I receive zero device incentives, so as a former employee I  pay the same as everyone else.  

 

Once my lease is finished,  my 20 plus years of being a loyal Sprint customer might end.  I'm already checking ebay for unlocked Note 8's that I can setup, prepaid, for a fraction of the cost of Sprint's network, post paid service.

 

LOL, yes, reading back my comments, I am sure my inability to easily unlock this Samsung S8+ has impacted my mental health.  God bless...

Apprentice

Hi bobpwilson! 

 

I don't use any Samsung account, or use any on body detection or any other means recommended by some other users. 

 

What I do know now is that due to some process that has 4 hour timeout, smartlock doesn't understand that it is at the same secure location. Also earlier I did test setting a multiple places around my home as secure locations when the Google Maps seemed to jump my location back and forth between the places around my home.

 

After the recent tests, I have noticed that thr best way to get the Smartlock to work operational after 4  hour timeout is:

 

1) Close Google Maps

2) Turn off the Location Pin

3) Close the lid or turn off the screen and Wait at least one minute before opening the phone screen again.

4) Type in your Pin and open Google Maps and ask it to show your location (target with a question mark button), which makes Google Maps to ask for your permission to turn on the Location Pin again. 

5) Zoom in the map until you see for sure that the blue location point with light blue circular area around it settles close to your secure area, it may take a while.

6) Leave Google Maps active and close the lid or turn off the screen and Wait at least one full minute before opening the phone again. When that minute has passed you should gain another 4 hours of use time again. 

 

I must admit that the instructions I describe above are quite complex and Google should definitely fix this issue, instead of sitting there in their ivory tower doing nothing. This is almost as annoying as seeing in Google Mail app in sent folder my own name instead of seeing there recipient's name which in this case is the only relevant information...

First Poster

What worked for me with Galaxy S8+, SM-G955U, Android 8.0.0, Samsung Experience 9.0:

Big picture is two key areas:

  • Under Settings… Lock Screen and Security… Smart Lock… Trusted places… add two or more pins to “cover” your home AND tap “Home” and turn OFF as a trusted place in Google Maps. (Warning:  Every time you go back into  Trusted places, it turns itself back on by default and must be turned off again before exiting)
  • Under Settings… Cloud and Accounts… Accounts… Samsung account… Places… Be sure Home address is correct. Then tap on address AND under Improve Detection be sure to confirm or add the name of your local Wi-Fi network.  (Aside:  I believe this may be key to benefiting from Settings… Connections… Location… Improve accuracy… Wi-Fi scanning ON)

I preceded all this by turning off Location, closing all apps, rebooting, opening Google Maps (location back on) and zooming in and waiting as necessary to be sure it was correctly locating the phone in my house. 

 

I have waited two weeks to submit this to be sure it has continued to work without fail.  It has.  I still have to enter my PIN after 4 hours (as designed), but no morning reboots or other extraordinary action necessary.  Can it be this simple or too good to be true?

Apprentice

Interesting!!! Google did some updates during last week which apparently made my Google Maps to crash randomly. 

Something good came out of it though. Now I can get 4 more hours with Smartlock just by turning the location pin on the top slide down Off and then a bit later Off and Smartlock starts to function again!!! Let's see how long this will last now...

Observer

This worked perfect for me, thank you! 

First Poster

Awesome tip - how do you do that?

Top Liked Authors