Support

Open search

Mobile data not working after disconnection from WiFi

First Poster
I managed to get it sorted
I called network provider and asked them to resend the network settings by txt Msg.. They sent it and i installed and works well again.
Apprentice

This worked for me also. I contacted Three and they resent my network settings. Now my 4G is up and running perfectly again.

Apprentice

Same here. Rather annoying on 3.

 

Hopefully that'll issue a fix soon.

 

 

First Poster

yes same issue on THREE UK network. Seems some people who reset default APN settings got it fixed but didnt work for me. 

3G works fine

Only issue is 4G

I disabled VoLTE and this worked for me, but obviously I want to be able to use VoLTE!

Have spoken to Three and Samsung and both blame eachother

 

We all need to make them both aware of the issue so they provide a fix in next software update

First Poster
when will there be a fix for this? many people affected. its not a sim or phone fault.
Apprentice

It's the most irritating thing. Switching on/off data only works some of the time too .

First Poster

Same for me. Will ring three tomorrow and see what will help. 

Apprentice

Problem is likely to be with the Samsung update. I guess three will send the APN details again, but will fail once you switch between WiFi and data.

 

I can't believe something such as this was never tested.

 

The extra clicks to change the settings seems so primitive. 

Apprentice

I've disabled VOLTE for now. Works well. Once Samsung fix it I'll re-enabled.

Explorer

I've also started to experience this problem (I have the dual SIM variant but only use it with one SIM and an SD card). Like others, I've found that either disabling VoLTE Calls - or toggling Flight Mode on and off when switching between WiFi and 3G/4G - restores my cellular data connectivity.

 

However this is not a solution, the phone did not do this out of the box. I'm pretty hacked off that I have to disable VoLTE Calls which is a useful feature for me.

 

Enabling/disabling Wifi Calling makes no difference. However if I have VoLTE Calls enabled while connected to a wifi network, if I disconnect, immediately I have no cellular data. It magically starts working the moment I disable VoLTE Calls in the Settings -> Connections -> Mobile Networks menu.

 

My phone was given a full ADB diagnostic by the Samsung engineers at a local service centre last week and nothing untoward was indicated by the tests. This appears to be a new bug introduced by the most recent OTA update.

Top Liked Authors