Support

Open search

How do I prevent the phone closing my background apps?

First Poster

For example, I play Pokemon Go and use the Go Plus Bluetooth device, therefore I'm able to play it with the app running in the background. However if I open another app, let's say I want to look at Facebook while using the Go Plus to play the game at the same time, within a minute the Plus is disconnected and the Pokemon Go app has been closed. When I go back to the app it has to restart and load up again. Same applies to all apps, Facebook, web browser etc.

How do I stop this happening?

11 REPLIES 11
Helping Hand
Did you turn on Developer options? Because there is an option in developers option that limits the amount of apps running in the background.
Found here:
Settings > Developer options > Limit Background Processe

Check if this is set to 1 or no background processes and change it to Standard limit or 4 at most.

---------
Never gonna give you up!
Mvg,
T.K.
First Poster
mine does the same thjbg - so annoying. It was doing it before I turned developer options as well. The processes are set to standard. There doesn't seem tk be any options to keep apps running at the background
New Member

This will obviously not work in all situations but it will for pokemon go as long as using half the screen won't be a deal breaker. Open it then long press the recent apps button so it opens a second window underneath Pokémon GO. Then you can use another app with half a screen and when you click back on the Pokemon Go app, it will work as supposed to.

 

I only tested this with PoGo and a few other Apps (Chrome, settings, messaging) 

Pathfinder

Not sure if this will work, but try going to Settings | Device maintenance  [renames Device Care in Pie]

Select Memory and add the app you want to keep awake to the ones that aren't checked.  In Pie it is on the hamburger menu top right of the screen - I can't remember where it is on Oreo but I think it may be at the end of the list of apps currently running.

 

New Member

Thanks this started happening after the last update. If they add a feature like that, why do the enable it automatically.

 

Some of the new colour scheme sucks too, makes it much harder to read what's on screen

First Poster
it doesn't help
New Member

I just tried what was recommended by others and it didn't work. But I came across a new story in the process and hoping for the best!

 

Go to system care, select battery, go to settings in the top left, and uncheck "put unused apps to sleep". My fingers are crossed for this to work.

 

This may also be an adjustment for each mode (I.e. I did this for my optimized mode ).

Observer

i have a similar issue but with a different game (dokkan battle). before the pie update the game was always in the bakgorund and never was forced closed. but now ever since i got pie on my note 8, i always have to reload the entire game every time i want to resume playing...  i am also looking for a solution. 

Observer

My Google Maps started closing with the new update while in background mode.  Setting, Apps, (select app), Battery, Allow background activity

Top Liked Authors