Support

Open search

Gmail delay notifications

Apprentice

Hi,

I just bought a S9 last week. When the phone is in my hand and I am using it, I receive gmail notification and email right away, but when I put my phone aside after a couple of minutes not using it the notification/emails will arrive very late. starting from 10 min late until hours late. In additon If i take my phone in my hand and open it all the mail notification will arrive asap. It is as if my phone/gmail goes to sleep/standby mode when I do not use it. I tried everything. Delete data and cache. resept app settings. reset network  settings reset, setting reset. uninstall and install gmail again. I have no battery optimization on for gmail. sync on the phone is on and sync on gmail setting is also on. I tried everything that can be found on the internet but was not able to solve this issue. gmail sync is arriving very late. help would be very much appreciated.

thanks

31 REPLIES 31
ChrisM Moderator
Moderator

Hi @Gargamel.

 

Did you manage to find a fix for this issue or are you still having the same problem?

Apprentice

Hi Chris,

 

I am still having the same issue. 

 

ChrisM Moderator
Moderator

Hi @Gargamel.

 

Is the software on your phone up to date? Go to Apps > Settings > Software update > Download updates manually. Also, let's try a soft reset on the phone. This will end all processes and give the phone a fresh start. To do this, press and hold the 'Power' and 'Volume Down' buttons until the phone restarts.

 

Are you only having the problem with Gmail? Do all other apps/notifications seem to work OK?

Apprentice

the software is the latest. I already tried and did a soft reset. yes it seems to be only with gmail.

 

AntS Moderator
Moderator

Hmm. Sounds very similar to what this Pixel user was experiencing. Any joy for you with what Wahur1 there tried in manually adjusting the notification settings for the folders/sub-folders under "Manage Labels" in the Gmail app itself?


Prince_Community_Sig03.jpg

 Say "Hello!" to the Community in The Introduce Yourself Thread.


Apprentice

unfortunately this is not the issue. i am only using one inbox, no subfolders. all the emails come into the one main inbox (Primary) . i had unchecked all the other ones ( primary: person to person conversations and messages that dont appear in other catogories. to receive all  mail in one inbox uncheck all the others) this is what i had done

 

I have talked to 2 other people who also do have a s9 and they also do get the gmail emails notifications late. 

 

AntS Moderator
Moderator

I'm guessing, that like yourself, they're using the Gmail app rather than Gmail on the stock email app.

 

Any differences between Wi-Fi and Mobile Data on the notification delay - or is it the same on both of those?


Prince_Community_Sig03.jpg

 Say "Hello!" to the Community in The Introduce Yourself Thread.


Apprentice

it seems to be the same on wifi and data.

what i noticed is, i now tried the 'email' that was preinstalled on the phone and have added my gmail email adress to it. now when my phone is on the side for  a while unused and i send a test email to my phone the 'email' does come first and somehow wakes up the gmail app and then the email arrives also in the gmail app.

 

 

AntS Moderator
Moderator

Interesting. 

 

From all that you've said it points to something going on in the Gmail app itself.

 

I know you've said that there's no battery optimisation set for the app, but just to confirm that all the stuff from the phone settings has been eliminated:

 

  • Settings > Apps > Gmail > Notifications > On Lock Screen, and make sure either 'Show Content' or 'Hide Content' is selected.
  • In Settings > Apps > 3 dots > Special Access > Optimise Battery Usage > Apps Not Optimised > All Apps, Gmail is definitely not enabled as 'Optimised'? And in Special Access > Allow Unrestricted Data Usage, what's the Gmail app set as?

Prince_Community_Sig03.jpg

 Say "Hello!" to the Community in The Introduce Yourself Thread.


Top Liked Authors