Support

Open search

Delayed notifications issue affecting all range of Samsung devices since at least half a year.

First Poster

I think I have really solved this mess. I was one of those who did factory reset, all optimization sh*t was turned off, whatever it was mentioned on the web I tried. There was a suggestion saying clear cache and data behind system app called "BadgeProvider". This still didn't solve it. But nobody has mentioned that we should check if "BadgeProvider" is one of the optimized apps or not. Bumm... taking it out seems to be working. So here is what I did:

 

Settings/Apps, here in the top right corner tap on the 3 dots symbol, tap on "Show system apps", find "BadgeProvider" and tap on it, then Storage, clear data + cache, reboot phone. Now search for "Optimize battery usage" in Settings. There is a drop down, choose All, find "BadgeProvider" switch it to inactive (=will not be optimized) 

Explorer

Thank you. Looks very promising, programmed alarms are now notified within one or two seconds, but will test more. Would be nice if others could test too. Cheers.

Observer

Sorry didn't work for me. Notifications work great when using mobile data. But when using wifi (virgin media) it works fine UNTIL the phone is inactive for a while (approx 15 mins). Then noneare received until I turn wifi off and then back on again. Annoying!. Tried all suggested fixes ...maybe new router required? Help please!  Ps Samsung j6 android 9

Apprentice

Unfortunately this did not work for me either. 

Explorer

NO it doesn’t work. You’re lucky its worked for you. I have tried all tweaks and it never worked. Even samsung remote service team and repair centre has tried many things. Believe me there is nothing you can do with this problem nor its worked unless samsung resolve this from their side. 

 

If anyone recommends any settings or tweaks it works for few batches not for everyone as I have tried all of these things and never work. FYI its brand new replaced device by samsung and there is nothing you can do atm. 

 

Only thing I would consider to flash different countries firmware and check but I havent used my mobile yet so need to use it for few minutes with EU sim. If anyone tried any different firmware and got it resolved then please let me know here. 

Explorer

Hello, 

Though the behaviour is a little different from last time, I'm afraid that this does not solve the problem for me. I spent a whole day again testing the notification delays for simple calendar events programmed every 15 minutes. The dalays ares a little different from previous time (twice on-time) but the average delays on my galaxy S9+ are of the same order of magnitude as before. Here are the late notifications between 07:00  and 19:00  they should be at 00 minutes, 15 minutes, 30 minutes and 45 minutes after each hour. They are not.

07:00:21   07:17:33   07:30:16   07:47:32   08:02:32   08:17:32   08:30:01   08:47:32   09:02:33   09:17:32   09:32:33

09:46:23   10:02:32   10:15:17   10:30:21   10:47:32   11:02:32   11:17:32   11:32:32   11:47:32   12:02:32   12:17:32   12:32:32

12:45:37   13:00:01   13:17:33   13:47:32   14:02:32   14:17:34   14:32:32   14:47:32   15:01:27   15:16:00   15:30:49   15:46:26

16:02:32   16:17:02   16:30:16   16:47:13   17:00:47   17:17:33   17:32:33   17:47:33   18:02:33   18:17:33   18:32:33   18:47:34

19:02:34  

In other words, that day roughly 2 and a half minutes late. During that same period the same notifications on my old Nexus 7 2013 were all precise within 1 or 2 seconds.

It is sad but this is not a solution for me, The Galaxy S9+ is an expensive phone. I want my notifications on-time.

Cheers.

 

 

 

Explorer
No it doesn’t work. I don’t know why but there is no any solution atm. Only if Samsung willing to resolve it, they can. They are not even acknowledging the problem.

Has any one tried different countries ROM with odin? It may work but not sure if it will be solution. Keep posting updates here.
First Poster

So a year ago when my S9 started doing this, I read something that said to disable Google. The only thing I really noticed I was missing was the ability to use voice features. Not a big deal for me, but some of you may really miss that. I would rather have timely notifications than voice to text, etc. I did it and it worked. I was hoping this would not effect my S10 but after 3 weeks, my new phone started doing the delay too. I was hoping to find a new fix so started following this board and tried everything that was suggested over the last 2 months. Nothing worked for me. So I disable Google again and it worked for me again, notification were coming in on time. Just to check I enabled it and notifications over the next 24 hrs began to delay more and more and apps wouldn't download right away. So I disabled it again and its been good for the last week. Again, you will loose the voice features (OK Google, voice to text, etc) on your phone.

 

If you want to try it, in your apps, find or from your apps screen search for google. Locate the large colorful G and in your apps menu hold it down until you get the small pop up menu. There should be an option to disable. Thats it, the app disappears from your app list but notifications and downloads work again. If you want to re-enable the app, to to Play Store and search for Google. It should be the first one, big colorful G. You can enable it from there. Hope it works for you if you try it.

Explorer

Thank you for posting solution here. I will try that and let you know. Except this I have tried all solutions so far and nothing worked. So lets hope with this method. If anyone has other solutions tested and working please do post here to help others.

Explorer

Disabled Google doesn’t work either. It creates more problems now. Few apps has stopped pushing notifications even screen wakes. 

Top Liked Authors