Open search

Moisture detected note 9

First Poster

Its a softwware problem for sure. it either needs correcting in the next update ASAP or writing out of the code. Happened to mine ONLY after the battery went 100% flat, not even enough to start to turn on. Tried different chargers, left phone and all equipment in the boiler cupboard over night (2 x chargers , cables and phone). Still the same 10 hour later. Tried the sugestion above to partially inset and its now charging switched off. Will see if it happens agin in the future. Been with Samsung since mobiles first came to the Uk and this is the first problem ever so giving them the benefit of being a one off glitch, if it happens again i will think of switching to another manufacturer.  Never buy the latest model so all the glitches can be ironed out, worker very well up to now. You need to up your game Samsung and stop burying your head in the sand !!

First Poster
Worked for me. Thanks
First Poster

I think the solution is to first clean out the port and then purchase some plugs. Type "usb c cover plug" in Amazon search and there are lots of options.

New Member

Hey guys, I hadn't dropped my phone in water and I was having this problem. I tried restarting it multiple times and it wouldn't even let me charge it when the phone was off. All I did to solve it was take the S Pen out and it immediately stopped. I barely use the pen so I doubt there was any moisture on it. I'm guessing it was a glitch. 

Just Browsing

Have same problem here

have does the same things too

So how long should I wait until I the message gone? (So I can charge)

I only have 9% battery left here and I still have no any wireless charger :(

New Member

Posting this in hope it helps someone. I tried everything after swimming with my phone in the Caribbean sea by accident. Nothing worked. Moisture detected warning wouldnt go away. A day later and blow drying it. Same thing. Wiping cache. Even factory reset. Nothing. Finally I turned the phone off and tried to recharge it that way. I had no choice because I was at 3 percent anyway and would have to do so anyway. It worked. When I restarted it while still plugged it kept charging. Solved.

New Member

Thank you, this fixed my phone which was never even close to water.  Cheers!

First Poster

Had this happen again. Dripped in some rubbing alcohol (isopropanol from any pharmacy), then rinsed with water, used a can of air to blow out the port. This worked again. The functionality of the port, or the message doesn't clear up immediately; it takes an hour or two after cleaning it out for some reason. The silicone plug for the port works great, but you need to remember to put it back in after using the port!

New Member

Thanks for the advice on this issue.  If it helps, I waited until after the first SAMSUNG the GALAXY NOTE 9 appeared and disappeared and then the SAMSUNG logo reappeared. I then pused the charger in fully and held it with a little more pressure than normal.  "0%" and the charging ring then appeared.  It's now at 1% so I know it's working.

This worked like a charm. I don't know why I didn't think to do this sooner. Thank you so much!!!
Top Liked Authors