Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Galaxy watch 4 - ecg - Your watch doesn't support this app - error

(Topic created on: 19-09-2021 01:16 PM)
Pabretel
Explorer
Options
Wearables
 
image
 
Just tried to use the ecg function and got this on galaxy watch 4. Been working previously 
0 Likes

1 Solution


Accepted Solutions
Solution
Pabretel
Explorer
Options
Wearables
Sorted it. I installed the update with nordvpn enabled and it worked

View solution in context

17 REPLIES 17
mrPMLawyer
First Poster
Options
Wearables

I am having the same issue here with my new Galaxy Watch 4.  First time trying to use this feature.

0 Likes
Pabretel
Explorer
Options
Wearables
Mine was working fine until last night. Contacted Samsung text support and I was told to wait for an update. Not holding my breath though.
0 Likes
Pabretel
Explorer
Options
Wearables
I get this. But when I tap on it I get the original error message I posted20210920_085623_1636.jpg
0 Likes
mrPMLawyer
First Poster
Options
Wearables

Same here.  I have been half an hour with Samsung support chat and nothing...

0 Likes
Pabretel
Explorer
Options
Wearables
Still can't use my ecg function on watch 4. Keeps saying I need to update the app to continue using but when I tap update it takes me to a blank Web page with an error.

image


image


0 Likes
GusB
Helping Hand
Options
Wearables
What phone do you have and what country do you live in
0 Likes
Pabretel
Explorer
Options
Wearables
S20 ultra and UK. Was working until couple of days ago
0 Likes
GusB
Helping Hand
Options
Wearables
Is there any update here on the watch?

Presume you've checked on your phone's galaxy app for any updateScreenshot_20210923_073126_settings~2_30134.pngScreenshot_20210923_073120_settings~2_30133.png
0 Likes
Pabretel
Explorer
Options
Wearables
I think there may be an update but I'm getting this 20210923_074320_11075.jpg
0 Likes