What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

WIFI repeatedly switching off and trying to reconnect

(Topic created on: 04-01-2023 12:12 AM)

2 Jan 2023

Have tried ALL the recommended troubleshooting suggestions (except factory reset) and it's still happening.  WIFI switches off then tries to reconnect every 2 seconds.

  Does anyone have a good solution?


  • reset phone
  • reset router
  • gone through the wifi/advanced and switch everything off
  • uninstalled the last app that did an update (only 2 apps updated in the last day)
  • checked wifi control history - only two apps have access to switch wifi on/off 
  • reset network settings

Is there a bug or recent update which has caused this?

argh!  can anyone please assist?

Samsung Members Star ★★

Hi @tree_house A few other suggestions in case you have not tried:

Go to Settings- Connections - Wi-Fi - Tap the cog symbol to the right of your router - Forget . This is the bottom right on the list. Toggle your Wi-Fi off and on again - Select your router from the list of available connections, and run through all the connection steps.

Thereafter go to Settings - Connections - Wi-Fi - Tap the cog next to your router on my device it is under view More but could be Advanced if that does not show. select the MAC Address Type and set this to Phone MAC. 

if not resolved could try wiping the cache partition by following steps:

1. Turn off the device.
2. Connect To Computer or plug in USB-C Headphones , Press and hold the Volume Up key and then press and hold the Power key
3. When the Android logo displays, release all three keys.
4. An 'Installing system update' message will show for 30 - 60 seconds before the Android system recovery menu options appear.
5. Press the Volume down key several times to highlight wipe cache partition.
6. Press Power key to select.
7. Press the Volume down key to highlight yes, them and press the Power key to select.
8. When the wipe cache partition is complete, Reboot system now is highlighted.
9. Press the Power key to restart the device.

I do not work for Samsung or make Samsung Products but provide independent advice and valuable contributions.

On a different post there was a similar issue, I thought I would try turning off all intelligent WiFi settings and disable WiFi calling, over the last 6 hours it seems to have worked but time will tell. I don't know which one change has improved it but if remains stable will introduce one at a time.
My galaxy a12 has that, its not as big of a deal as you say it is