Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

WiFi Calling on S20+ not working correctly

(Topic created on: 24-01-2023 01:25 PM)
628 Views
Duncs5
First Poster
Options
My WiFi calling does not work all the time when it is switched on. My phone network coverage is very poor in my area so I rely on WiFi calling.

Sometimes the WiFi calling symbol comes on and other times it is not, even though I am connected to WiFi. Is there a way to have WiFi calling on permanently when you are connected to WiFi so your phone doesn't toggle between your mobile network and WiFi calling?

If you have WiFi calling switched on and you are connected to WiFi should the WiFi symbol come up immediately in the notifications bar as this doesn't happen with my Samsung S20+ phone? 
2 REPLIES 2
Jimboo84
Black Belt 
Options

@Duncs5 

funny to read  this article now. I struggled  for months with this issue on Proximus(Belgium), but at other providers it worked fluently. Indeed, it should pop-up immediatly.

Proximus pushed the last Modem software version to my modem and it was fixed. Note: factory reset is NOT the same, I did this 1000 of times.... Check with the modem's provider and ask for the latest version or a newer modem. Could be your hardware is already outdated

0 Likes
BandOfBrothers
Samsung Members Star ★★
Options

What maybe happening is that if you have even the slimmest network connection your phone will choose that and will flit to Wi-Fi calling if it completely fails.

Maybe turn on flight mode to force only Wi-Fi calling !


Daily Driver > Samsung Galaxy s²⁴ Ultra 512Gb ~ Titanium Black.

The advice I offer is my own and does not represent Samsung’s position.
I'm here to help. " This is the way. "

0 Likes