Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Whatsapp keeps telling me your phone is not connected!

(Topic created on: 11-03-2021 01:41 AM)
12858 Views
Specialist
Pathfinder
Options

So I just got the S21U today, and everything is wonderful so far, but could not figure out how to make sure whatsapp stays running in the background....

 Background usage limits = put unused apps to sleep is OFF

sleeping apps/deep sleeping apps/ never sleeping apps is 0

I went into Optimise Battery Usage, and made sure NONE of the apps or services are enabled (so no optimization for anything!!!) 

I even tried, enabling Battery optimization, and then adding whatsapp to NEVER sleeping apps.  (did not change the behaviour)

"Allow background activity is selected" ..  (I tried turning on and off Put unused apps to sleep) IT is now off, as it made no difference. 

On all my other phones this seems to be working, never even had to do any of these settings. 

The only thing that makes sense is Power Saving MODE OFF! but the description udner it...

 

Learning usage patterns... 

 

Background network usage, syncing, and location checking will be limited and motion smoothness will be changed to standard.

I work all day and I need to be online on WhatsApp, what am I going to do, set the screen to never turn off so that the device is awake 24/7? 

Any suggestions? 

 

Thank you. 

38 REPLIES 38
Specialist
Pathfinder
Options
This does not work at all.... That is the first thing I do when I get a brand new phone in my hands, after first boot disable all battery optimisations.. Adaptive battery is the first toggle that gets switched off.
0 Likes
mccx
Student
Options

Same here, I turned off all sleep apps, adaptive, battery/power, DND, and background limit settings.  Whatsapp still goes to sleep in a little while after screen is turned off.   From that point on, I stopped getting notifications/messages/calls (also GPS location sharing) until I wake the screen up.

Samsung please fix it ASAP!   The phone become unusable if I can't get notification that I needed in real time.

0 Likes
Specialist
Pathfinder
Options
Did the battery optimisation finish (are you seeing estimates in the battery screen?) the second it started doing that everything started working, never had the issue again
0 Likes
Mirkinen
Explorer
Options

Didnt work for me

Zo_R
First Poster
Options

Does this happen while connected to Mobile Data only or also on Wifi?

0 Likes
Zo_R
First Poster
Options

Battery lasts 26 hours for you with the Adaptive Battery feature turned off? 

0 Likes
Specialist
Pathfinder
Options
Not constant screen ontime, but yes
0 Likes
Hasbean
First Poster
Options

I am experiencing this issue and finding that I do not get WhatsApp calls and texts when the screen goes off. The phone is stationary most of the time with all battery optimization turned off, mobile data turned off and wifi on.  I guess if I walked about with the phone in my hand all the time it would work ok :winking-face:  Having read several other posts re this problem I suspect that the wifi connection process is being put to sleep and there is no setting to prevent this from happening. As mentioned by OP this is quite a serious problem and needs fixing.

0 Likes
Mirkinen
Explorer
Options

If I'm on Wifi I don't have this problem. 

This is a sh*tshow anyway. Samsung is silent and we are left we an half working app.

If their idea of making the battery last longer is to stop app from working, well ***** done. 

0 Likes
Specialist
Pathfinder
Options
You need to disable all sleeping apps, when i got my phone it had over 200 apps and services sleeping... I removed all
0 Likes