Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Whatsapp keeps telling me your phone is not connected!

(Topic created on: 25-03-2021 09:45 AM)
8579 Views
Specialist
Pathfinder
Options

So I just got the S21U today, and everything is wonderful so far, but could not figure out how to make sure whatsapp stays running in the background....

 Background usage limits = put unused apps to sleep is OFF

sleeping apps/deep sleeping apps/ never sleeping apps is 0

I went into Optimise Battery Usage, and made sure NONE of the apps or services are enabled (so no optimization for anything!!!) 

I even tried, enabling Battery optimization, and then adding whatsapp to NEVER sleeping apps.  (did not change the behaviour)

"Allow background activity is selected" ..  (I tried turning on and off Put unused apps to sleep) IT is now off, as it made no difference. 

On all my other phones this seems to be working, never even had to do any of these settings. 

The only thing that makes sense is Power Saving MODE OFF! but the description udner it...

 

Learning usage patterns... 

 

Background network usage, syncing, and location checking will be limited and motion smoothness will be changed to standard.

I work all day and I need to be online on WhatsApp, what am I going to do, set the screen to never turn off so that the device is awake 24/7? 

Any suggestions? 

 

Thank you. 

38 REPLIES 38
NB
Pioneer
Options
Do you see this option turned on?

Screenshot_20210311-021150_Samsung Members_12628.jpg

0 Likes
Specialist
Pathfinder
Options

Yes Vodafone in the UK supports WiFi calling, and in my office I don't get good signal that is why I use WiFi calling.

 

I will disable it and try but logically WiFi calling shouldn't interfere with this. 

0 Likes
NB
Pioneer
Options
No that's not what I meant. Could you use this feature in WhatsApp?
0 Likes
Specialist
Pathfinder
Options

No.

 

That feature is, if you turn flight mode on or you don't have mobile signal you can still make calls by using your WiFi.

 

It has nothing to do with WhatsApp 

0 Likes
Mirkinen
Explorer
Options

Same issue. Both on Whatsapp and Whatsapp business.
Samsung please.

0 Likes
Marcusm18
First Poster
Options

Same issue, need severe help.

0 Likes
Specialist
Pathfinder
Options
Drain your battery as fast as you can. I drained the battery 3 times or 4 times from 100 until 15 or 10 and 5 percent. Fully charged it slowly (disable fast charging and super fast charging.) takes about 2 hours to charge.

After this finally battery estimates started showing.. (I am thinking that during what Samsung calls battery optimisation period) they do some sort of black magic on the background and completely ignore android settings, because why not "we are Samsung, you pay thousands for our phones to not be able to use it"...

So after this period I don't seem to have issues....

But the first thing I don't when I got the phone and the issue started happening was the following.

1) go battery optimisations, turn off all options such as adaptive optimisation, put apps to sleep etc.
2) go into sleeping apps and make sure there are no sleeping apps (putting WhatsApp into the never sleeping apps will not work) during Samsung battery optimisation period.

I have removed all apps and services from optimising, so that nothing is optimised.

And after optimisation period ended, I gotten 11 hour screen on time with a total of 26 hours or something like that standby time... None of my previous Samsungs ever lasted 24 hours without without charging...


This message is for Samsung.... Whatever you are doing you seem to be not allowing more than 2 background processes for apps during battery optimisation....

Its not a coincidence that after the battery optimisation finished apps that did not run more than 1 process (despite me playing with the limit options in developer options) suddenly started having multiple background processes....


So bottom line is, those who have this issue use your phone until battery estimates start showing and most likely your issue will be fixed.

Because since that happened I haven't had 1 single disconnect from WhatsApp web.

And I can guarantee that this is a Samsung issue and not WhatsApp related because I have multiple android phones (multiple brands) mainly Samsung and this does not happen on any Samsung phone except for the latest s21u.

Hope you fix this Samsung
hindraxxx
Apprentice
Options

you can fix this issue by turning off adaptive battery on the setting 

0 Likes
Mirkinen
Explorer
Options

No, that doesn't work. Mine is off already. 

0 Likes