Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Sleep mode keeps activating alarm no matter what

(Topic created on: 13-02-2023 02:38 PM)
25925 Views
VinMar
Explorer
Options

Sleep mode keeps activating the alarm no matter what I do. I have gone into the settings and dug down to turn it off and saved it but it reactivates next time. I deleted the current sleep mode then rebooted the phone and recreated it turning off the alarm but it still insists on turning it back on. I've stopped the app cleared the cache pretty much everything I could think of and it persists.

I've finally deleted sleep mode completely and just use the do not disturb under notifications and it's no problem. If you have other options you want to change during do not disturb most can be written into a routine that runs at a specified time period you can set parallel to sleep mode. Sure it's a pain but less painful than the bug that keeps arming the alarm.

Samsung you need to fix this.

3 Solutions


Accepted Solutions
Solution
VinMar
Explorer
Options

Yes read earlier post for the workaround 

View solution in context

0 Likes
Solution
VinMar
Explorer
Options

As previously stated a couple times in the posts there is only a work around.

1: Delete sleep mode completely

2: It you want a "Do Not Disturb" turn it on under notifications.

3: If you want to change system settings such as greyscale etc. during DND time create a routine to do so.

You need to know how to use your phone I'm not giving a step by step in a post.

View solution in context

0 Likes
Solution
Hetrab
First Poster
Options

I have a solution that turns off the alarm permanently and maintains the features of Sleep... From settings go into Modes and Routines, select the sleep mode. From the Sleep settings screen click on Turn On Automatically. Toggle the time at the top of the screen to off.  Toggle on "Time Period" at the bottom of the menu instead.  This will activate the mode but not the alarm. Problem solved! This has worked for me and not triggered the alarm daily. Best of luck!

Screenshot_20230221_223034_Modes and Routines.jpg

View solution in context

73 REPLIES 73
CharlW
First Poster
Options
Yes this is driving me mad. It seems to have started after a recent system update. Before that the sleep alarm was off and stayed off. I am having to resort to deleting the sleep mode which seems counterintuitive
Sir Avalon
First Poster
Options

I have the same problem 😞 ,   driving me nuts........... 

VinMar
Explorer
Options

I forgot to mention it happened to me after the last update beginning of February it was fine before that. I don't care about dimming screens and all that junk so I just use the do not disturb settings under the notifications setting instead and deleted the sleep mode. Actually I don't use any of the modes they seem redundant to other settings and are pretty useless as far as I can see. For example Drivers Mode, I have Android Auto that already loads automatically so what is the point. I also have a script to turn on my hotspot when connected to my truck so it can share my wifi.

mangojelly
Journeyman
Options

This also recently started happening to me on my S21. It seems to reset the settings each day and add the alarm back. I like the sleep settings instead of just do not disturb because of other settings like dark mode & eye comfort shield. 

VinMar
Explorer
Options

If you don't want the alarm then you can still delete the mode, use the do not disturb in the notifications settings and then create a routine that runs at the same time period that turns on dark mode and eye comfort shield. Pretty simple to do and get's rid of the aggravating alarm.

Littlepie
Journeyman
Options

Having the same problem. There was a whole other thread about issues with sleep mode activating (or not activating) correctly which appears to have been deleted? I had been using a workaround of adding a custom Sleep Mode which was working, but now the original Sleep Mode is turning an alarm on at 'wake' time that I didn't activate.

Members_j024l9O
First Poster
Options

I have this issue to (s22 ultra, OneUI 5.1 etc). Sad that Samsung wont comment on it.

Rodney5
Explorer
Options
Same problem here - infuriating! Is there a way to turn on greyscale without having sleep mode turned on?
mangojelly
Journeyman
Options

Thanks, seems like a doable workaround but hopefully Samsung can also fix the problem. I see in my routines "sleep" is activated (didn't realize this is where you can edit it, because I always did it from my clock app).
Maybe creating a new routine instead of the default sleep one and adding DND & eye shield, etc. will also work. I'll try that.