What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Charging wirelessly ONLY - no charging with cable

(Topic created on: 02-04-2022 01:58 PM)
First Poster

Hi there,

I have a Samsung S21 Ultra 5G and since last week it no longer charges with a cable - only wirelessly.

I've changed cables - I've changed adapters and tried anything to make it charge with cable all to no avail.

The funny part is that when I use any charger onto the wireless charging stand it will charge - if I use the same adapter direct to the phone it will not charge.

I've cleaned the bottom socket where the cable sits with toothbrush and the cable fits snuggly with no movement- so it does not feel lose at all.

The phone was bought on 4th November 2021 so only 5 months old.

Never been dropped - it's like new.

Basically I'm at a total loos as I've tried everything.

I've called the people I bought it from - - they said take it to the manufacturer, so I called Samsung only to be told that the IMEI number says it was from Singapore and not a European model so they will not cover warranty.

Dimprice want £50 to check out the phone and they said it would take 60 days to return. So my thought is that maybe a Singapore phone that I was sold by Dimprice uses different voltages?? Only guessing but would like a better opinion.






Helping Hand
Would think it's unlikely to be a voltage issue as Singapore supply is 230v so is the same as UK domestic. The power adapters would work in exactly the same way and deliver similair ampere.
It sounds more like a faulty port on the device; either external on the pins or something internal on the connection to the main board.
If you have a PC then I'd suggest plugging the cable into the device and then into the PC and seeing if the PC detects it as am external device or data storage. If it doesn't then it's most likely a defective port, although reading about the dimprice sellers reviews it's not the first hooky device then have sold.

If it is the port then it can be repaired easily. At work we use a little place in Sheffield to do repairs on handsets - fonefunshop. Maybe give them a call and explain the issue about charging. They may be able to assist.
First Poster

Thank you so much for your reply.

The latest on the issue now is that when I put the mobile on the wireless charging stand or on the cable, it gives me time to full - this showing that it recognises the wireless charging stand and also recognises the cable. However, it stays on the same percentage charge.

Yesterday evening I put it on charge and it showed 42% 

This morning it was still showing 42%

Although I agree it could be the port - but the connection is very sturdy and does not feel in any way lose or a connection gone on it.

Now that is shows the same on wireless charging as on direct cable charging I'm wondering if this could be firmware? Or an update to firmware.

Again, I'm guessing but it will be a process of elimination.

I'm very intrigued as to what this problem could be?

When I received the unit it was boxed with seals - I think use the tax evasion to make them cheaper. Of course I will never use them again but as a customer I still feel Samsung is Samsung and they should honour the warranty. It will make me think twice now buying anything Samsung.