Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

990 Pro 2TB not showing in Magician - SOLVED

(Topic created on: 03-03-2024 09:34 PM)
1382 Views
Harrison2
First Poster
Options

Hello,

I have recently Installed a new 990 Pro 2TB NVME drive into my motherboard's second slot, but the nvme is not being recognised by the Samsung Magician tool. I have attached a printscreen of what I mean. The magician recgonises my other two drives and allows for edits/updates/etc., but my new drive is nowhere to be seen.

Harrison2_0-1709501158070.png

So far I have tried:

  • Updating the drivers via windows device manager
  • Uninstalling the drive via windows device manager
  • Re-formatting the drive via windows disk management
  • Updating firmware via NVMe SSD-990 PRO Series Firmware ISO file on Samsung's Tool & Software page

Other information:

  • I am on Samsung Magician Software version 8.0.1
  • The drive is accessible through windows file explorer and I have successfully downloaded and ran a Steam game from it.
  • I have recently installed a new motherboard in order to facilitate the second NVME which is the ROG STRIX B550-F GAMING WIFI II.

Any help would be greatly appreciated. Thanks.

 

EDIT - SOLVED

Ended up fixing the issue after a couple steps. Not quite sure which was the fix but they were:

  • Swapped 990 Pro into other NVME slot
  • Cleaned drive using diskpart in cmd
  • Converted drive to GPT type using diskpart in cmd
  • Clean install of windows onto the 990 Pro 2TB via a USB boot drive
  • Put the 990 Pro back into its original slot
  • Reinstalling Samsung Magician onto clean Windows install
0 Likes
1 REPLY 1
joseivanbeau
First Poster
Options

Hi

I have the same issue several time, My Computer has an ASROCk x670e pg lightning, just 6 months old.  Currently the system drive is an MSI 1tb, so I decide to at the 990PRO for gaming.   Suddenly after several months the drive just dissapear from windows 11.  Reboot the computer to find out the drive still showing in the BIOS.  Restart the computer and reapears in windows again, ran the diagnostic no issues.  Open a RMA and Closed it because the drive was working normal again.  Today the drive dissapear, restarted once no show.  Restarted 2nd time check the bios, drives was listed, then complete the boot cycle and the drive reappears again, no issues after that.   Somebody from SAMSUNG needs to explain what is the issue.  I was thinking the Main Board may have some issue, but after knowing that this is happening again to other users with different Main Board, I understand the issue is the drive.  The situations is I open an RMA they will send me a refurbished drive.

0 Likes