What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Watch 6 classic Tap And Hold function not responding

(Topic created on: 02-01-2024 11:05 AM)
First Poster

Hi, I have a watch 6 classic 47mm lte bought in August 2023.

After the most recent software updates, I started to have issues with a watchface I'd bought. I'd lost the ability to customise it via the wearable app, so the only way to customise was to use the tap and hold method on the watch face to open the customisation menu which allowed me to access the complications etc.

As of yesterday 01.01.24 the watch is no longer responding to this. No matter what watch face I have displayed, if I press and hold on the centre of the screen nothing happens. Had anyone else experienced this? If so can it be reset? Is it maybe something in a menu I've pressed in error?

I've tried a reset and still no changed. All software is up to date and I'm reluctant to go near developer menus or other hidden menus to reset settings incase I do something I can't fix.