Open search

Term and conditions notification on Galaxy watch


Bought new Galaxy watch. It keeps messaging me reference new terms and conditions and to click on a link, which i do. This takes me to my Samsung account on my phone. I have looked at these new terms but there is no tick box to agree to this. Any ideas?

First Poster

Likewise, my Galaxy Watch 46mm does the same, several times everyday. 


Mine is paired to Galaxy Watch IOS application, on iPhone X. To remedy, I’ve attempted:


- rebooting watch.

- unpairing and repairing BT and LE.

- uninstalling and reinstalling IOS app.

- resetting watch back to factory config.

- agreeing to terms and conditions on the watch version of “Galaxy Apps” app.

- scrolling through all versions of t&cs on both Samsung web page, Galaxy Watch app, and Galaxy Watch.


NONE of the above have made any difference.


I note from researching previous reported articles, this fault is not standalone to the Galaxy Watch only, rather has been reported on the previous generation of S3. (I own both the classic and frontier versions, but have not witnessed this fault until owning the Galaxy Watch.)


it is disappointing, considering the price point, and (having read previous articles) recognise Samsung Spt have not provided a solution to the fault in over 12-months). 


Thanks JD10 for replying. I have done all that you have done (although I have an S8 phone) I also have a problem with downloading apps onto the watch as it says that I have to verify my identity before downloading. I am not sure of how this is done either! I am learning to ignore the terms and conditions message, hopefully someone can solve this issue soon! 


Had the same problem with terms bug, drove me crazy, finally found a simple the Galaxy Wearable app go to the bottom "About Watch", then "Samsung Account", press the three dotted menu on the top right, open "Notices"...connects to your account on the web. I do not remember if I opened the first update "Privacy Policy", but the terms bug no longer bothers me on the watch. Worked for me, good luck!


Many thanks Lucas. I shall give it a go! 


Has anybody figured this out yet?

I contacted Samsung Customer Services re this issue on GW, and was advised to send my watch back to Samsung (for them to issue a replacement). I did, but still awaiting replacement over 2 weeks later, despite Samsung quoting such would only take 3 days.


My advice: reach out to Samsung Customer Services. This issue does not seem fixable with user operated procedure.


Thank you JD10 for your reply. I have learnt to live with this 'quirk'. I'm almost at the point of being able to ignore it! My watch can go for days without the notification popping up and on other days it's nearly every hour! C'est la vie 😁

First Poster


I did have the same problem with my galaxy watch. But I do have the answer:

Go to:

Login, accept conditions, reboot watch and that should do the job ! 

You're welcome :smiling-face:

First Poster

I sure won't be interested in upgrading to a new upcoming version.  I get ongoing, many times daily interruptions from the "terms and conditions message" which makes the watch difficult to use as intended.


I tried everything in every Samsung support group.  Just caused me all kinds of lost time.


Nope. Nope. Nope.  Samsung wearable is broken badly.

Top Liked Authors