Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Samsung Health snore detection not working with Watch 4 classic and Galaxy Note 10

(Topic created on: 01-09-2021 02:05 PM)
bmbougie
Journeyman
Options
Wearables

I just got a Watch 4 classic and almost everything works fine. It tracks my sleep and oxygen levels while sleeping, but the snore detection is not working. 

I have my phone plugged in and it is on a flat surface near my head. My watch knows I am sleeping, so why doesn't the snore detection work? I tried changing permissions, turned them all on for a couple nights even, but still it doesn't work. 

How close to my head does my phone need to be? Does it matter if it is a few inches lower than my head? Do I have to be facing it all night? Does the room need to be silent? Any suggestions on getting snore detection to work would be appreciated. Thanks!

 

edit: I plug in my phone and put it near my head when I sleep. I have it set to check for snoring every night. It works sometimes. One night I had tons of recordings, one night only 1, but mostly it is 0 because it doesn't work. I think it has something to do with where the phone is, how close to my head it is, because my watch/phone records my sleep just fine; if it knows I am asleep, it should be checking for snoring. 

Anyway, I am giving up on this. I know I snore and it should work and has worked, but it's unreliable. I'm just glad the oxygen levels record while sleeping, that's more important than snoring. 

43 REPLIES 43
P16
First Poster
Options
Wearables

SAME HERE,  SNORING NOT DETECTING.. s10+ 

0 Likes
lisafox16
Voyager
Options
Wearables

Tested this out and it only works if set to once only and not always. Just means you have to make sure you select once only each night. Hopefully an update will rectify this.

Chris_I
Apprentice
Options
Wearables
Not working on my Note 10 Plus 5G either. All the relevant permissions are switched on. Makes no difference whether recording is set to always or once only.
0 Likes
AndrewL
Moderator
Moderator
Options
Wearables

On your phone, please can you head to Settings > Apps > Samsung Health, and scroll to the bottom to find the current version. In the Watch 4 user manual it states, "The snoring detection feature can be activated on the Samsung Health app (version 6.18 or higher) of the connected smartphone. Also, you must place the connected smartphone’s microphone so it faces you. If your phone's Health app meets the required specifications, and you have enabled the measurements on your watch (S Health > Settings > Measurements > Snore Detection) then you should be good to go. 

0 Likes
Siebrand
Apprentice
Options
Wearables

I am pretty sure the 'Always' button leads to a line of code that says: // to be implemented

jamal27
First Poster
Options
Wearables

It looks so simple and obvious when you say it, but of course it's not working. I've been using the version 6.18.8.005 and I even saw the Notification of the Android Service claiming that the microphone was on use, but in any of my tries I see data about snoring. Verified many times the options and configurations along with permissions even before your message or posting here for the first time. It would be much better to have someone involved from the Engineering Team than someone from Customer Service who reads the steps to reply in the thread from a FAQ document. 

bmbougie
Journeyman
Options
Wearables

I have all the setting correct and I have the phone plugged in and facing me. The problem is that it works only occasionally. One night it had tons of recordings, one night it had 2, and most nights it has none. Also, the recordings disappear after I go into the app once, even if I don't listen to them. And I have them set to save for 31 days.

It seems the app just isn't very good and needs some tweaking. Kind of a disappointment, but at least the oxygen monitoring during sleep works consistently. 

0 Likes
RubyMouse
Apprentice
Options
Wearables

Mine is not working either. I have had it for 2 weeks now and it's hard to believe I didn't snore once in that time. I get "no data" every morning.

0 Likes
bmbougie
Journeyman
Options
Wearables

Try putting the phone right next to your head with the top towards you. When it worked for me I think it was closer to my face than some night's it didnt work. 

0 Likes
Sdrexler
First Poster
Options
Wearables

It worked when I first got the watch. I think th 8/25 update broke the functionality.