Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

S3 Watch has a lot of bugs

(Topic created on: 30-08-2020 12:40 PM)
Xwansier
First Poster
Options
Wearables

I have had this watch for over a month now. I can't download apps directly from the watch because I am constantly receiving a message that "The Terms and Conditions and the Privacy Policy for your Samsung account have been updated. Tap the link below to read and accept the new terms, then sign in again."
Now, I have googled this and followed the only 4 threads I could find about this and none of them worked. I factory reset the watch to no avail and I have tried using the findmymobile page to sign in and accept the terms there. I got the terms, I accepted the terms, yet it says I need to. This makes absolutely no sense. I can't get the notification to stop!

On top of that, I thought that maybe updating the watch would work. I got on the wearable's app from my phone and chose to check watch updates. There was one, so I chose to download and install. About halfway through "Copying update" it just gives up, stops, and from there, my watch's alarm app just won't work at all. Not sure how those are connected but it didn't break until I tried to update.


Not looking good Samsung. This is my first smartwatch purchase and I'm starting to feel like I should have just stuck with a regular analog watch. $100+ isn't worth a headache. Until this gets answered for sure, I am going to do my part to spread the word of how terrible these watches are. 

0 Likes
0 REPLIES 0