Support

Open search

Right galaxy bud won't connect after overheating.

Highlighted
New Member

When I went to use my galaxy buds this morning I found the right one to be hot. I dont know why it was hot because I left the case in a shaded area over night. When I used the right bud there was a beeping but the audio worked perfectly. I left it to cool for a while and when i returned to use it cam no longer connect to any of my devices. I've tried restarting my device and the buds, charging the buds and impairing and pairing the buds to no avail. The left bud wasnt hoylt and is working perfectly fine. Can I please have some assistance?

3 REPLIES 3
Highlighted
Moderator
Moderator

Hey @Ewan21! Can you clear the data of your device's Bluetooth Settings? On a Samsung phone this can be done via: 

Settings > Apps > 3 dots (top right) > Show System Apps > Bluetooth > Storage > Clear Data. Also, make sure that the device you are connecting the Galaxy Buds to is up to date. Try also this step: put your Galaxy Buds back in their case for 10-15 seconds > Reopen the case to enable Bluetooth connecting mode, and check your mobile device's screen to see if the buds are connected. 

Highlighted
Just tried that and none of those methods worked. Thanks for the help though.
Highlighted

No problem. You also mentioned that you tried with different devices and it is still the same? If so, it would be best to get in touch with Samsung Technical Support as the buds may need to be checked by an engineer: https://www.samsung.com/uk/support/livechat/

Top Liked Authors