Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

MyFitnessPal and Samsung Health not connecting any longer (steps)

(Topic created on: 30-08-2019 04:03 PM)
twizlan
Apprentice
Options
Wearables

Hello, anyone having this issue?

 

As of today I noticed that my steps from my Galaxy Watch Active, recording in Samsung Health, were not being synced to MyFitnessPal.

 

In the settings for Samsung Health, it no longer offers me the options for allowing read/write access for each data item, it just has 1 toggle "all permissions". 

 

In the Apps Connected area of MyFitnessPal, it now just says "connect" under Samsung Health, I click on it, it opens a little menu with 1 item of data "all permissions". 

 

It seems as though the actual permissions have been broken with the last update.

 

I have tried the following:

- Clear cache on both, then restarted.

- Reinstall both apps fresh.

 

I am now at the end of the road, I think it could be the latest update causing issue, which was 2 days ago (For Samsung Health).

 

Reading the reviews on the Galaxy App Store it looks like multiple other people are having this issue since the last update.

 

Just trying to raise visibility.

T

 

Edit: A workaround has been identified that seems to be working! Credit to the below. 

 

@Gisbourne wrote:
Hi all,


Find this workaround while browsing the MyFitnessPal forums which seems to be working...

megapsyk
Aug 30, 2019 01:20PM PDT

I found this comment on a Google Play app called 'Health Sync:

Samsung Health missing permissionsSamsung withdrew accidentally all permissions for Health Sync on August 30, 2019. We are in contact with Samsung to fix this. Temporarily you can use the special developers mode in Samsung Health as workaround. This doesn't do any harm. Open Samsung Health, go to the Settings menu, choose 'About Samsung Health' and tap the version number ten times in a row.'

I tried this and I can sync now. Either they fixed the issue or the developers mode worked.

Good luck 😊

 

 

53 REPLIES 53
Shamus
First Poster
Options
Wearables

Been trying to find a solution for this all morning and nothing was working until now.  I can't believe that an update is what has caused the issue.

 

This sounds bizarre, but this solution actually works. Tapping the version number 10 times, or until it expands works. I then went back to MFP & apps & devices and samsung is now a connected device!!

Thankyou greatly for this solution. Hopefully Samsung will fix this bug.

0 Likes
Matawna
First Poster
Options
Wearables

That workaround did nothing.  Very frustrating for this to happen.  Hope they fix it soon.

0 Likes
CountStex
First Poster
Options
Wearables

Seems to still be an issue, but this workaround is a good solution.

The_sandman
Explorer
Options
Wearables

Switching to the developer mode did the trick for me.

 

However, there was another update to the app pushed out today which seems to have fixed the permissions bug, i've switched back out of the developer mode (using the same process) and it all seems to be working still. :hand-with-index-and-middle-fingers-crossed:


Note9 128GB Midnight Black


Galaxy Watch 46mm


Tab s5e Wi-Fi

Scotchguarrd
First Poster
Options
Wearables

Thanks! That worked for me!


@Gisbourne wrote:

Hi all,

 
Find this workaround while browsing the MyFitnessPal forums which seems to be working...
 
 megapsyk
Aug 30, 2019 01:20PM PDT
 
I found this comment on a Google Play app called 'Health Sync:
 
Samsung Health missing permissionsSamsung withdrew accidentally all permissions for Health Sync on August 30, 2019. We are in contact with Samsung to fix this. Temporarily you can use the special developers mode in Samsung Health as workaround. This doesn't do any harm. Open Samsung Health, go to the Settings menu, choose 'About Samsung Health' and tap the version number ten times in a row.'
 
I tried this and I can sync now. Either they fixed the issue or the developers mode worked.
 
Good luck 😊

 

0 Likes
Emasullivan
Explorer
Options
Wearables

I noticed a similar issue, I've gone from a fitbit to the Watch Active 2 and it wouldnt connect MFP to SHealth at first, now it has it's unnable to sync my steps and just comes up with an error message each time.... slightly annoying!

0 Likes
RuthRM
First Poster
Options
Wearables

Thank you so much!  All fixed and working now - very happy,

0 Likes
yooby2
First Poster
Options
Wearables

 Getting the developer version worked! I had go very deep into the settings of each app to give all permissions, all the time, everywhere. But eventually everything synced up! Thank you! 

Keep poking at those permissions. Some are buried pretty deep...

0 Likes
Mindy2496
First Poster
Options
Wearables

I just purchased an Active 2 watch and connected using the workaround and it fixed the syncing issue. I had to tap the version number more than ten times, so just keep tapping until it changes to *(Developer Mode)* before your version number. 

 

Workaround:

Samsung Health missing permissions.

Samsung withdrew accidentally all permissions for Health Sync on August 30, 2019. We are in contact with Samsung to fix this. Temporarily you can use the special developers mode in Samsung Health as workaround. This doesn't do any harm. Open Samsung Health, go to the Settings menu, choose 'About Samsung Health' and tap the version number ten times in a row.'

0 Likes
Tammy70
First Poster
Options
Wearables

When i attempt to add a step tracker i get an error message the server cannot be reached. 

0 Likes