Support

Open search

MyFitnessPal and Samsung Health not connecting any longer (steps)

Highlighted
Apprentice

Hello, anyone having this issue?

 

As of today I noticed that my steps from my Galaxy Watch Active, recording in Samsung Health, were not being synced to MyFitnessPal.

 

In the settings for Samsung Health, it no longer offers me the options for allowing read/write access for each data item, it just has 1 toggle "all permissions". 

 

In the Apps Connected area of MyFitnessPal, it now just says "connect" under Samsung Health, I click on it, it opens a little menu with 1 item of data "all permissions". 

 

It seems as though the actual permissions have been broken with the last update.

 

I have tried the following:

- Clear cache on both, then restarted.

- Reinstall both apps fresh.

 

I am now at the end of the road, I think it could be the latest update causing issue, which was 2 days ago (For Samsung Health).

 

Reading the reviews on the Galaxy App Store it looks like multiple other people are having this issue since the last update.

 

Just trying to raise visibility.

T

 

Edit: A workaround has been identified that seems to be working! Credit to the below. 

 

@Gisbourne wrote:
Hi all,


Find this workaround while browsing the MyFitnessPal forums which seems to be working...

megapsyk
Aug 30, 2019 01:20PM PDT

I found this comment on a Google Play app called 'Health Sync:

Samsung Health missing permissionsSamsung withdrew accidentally all permissions for Health Sync on August 30, 2019. We are in contact with Samsung to fix this. Temporarily you can use the special developers mode in Samsung Health as workaround. This doesn't do any harm. Open Samsung Health, go to the Settings menu, choose 'About Samsung Health' and tap the version number ten times in a row.'

I tried this and I can sync now. Either they fixed the issue or the developers mode worked.

Good luck 😊

 

 

42 REPLIES 42
Highlighted
New Member

I tried all of the above, clicking on version number etc to get to developer mode and still nothing worked. But I had been using fitbit until now to track my exercise and just moved to the Samsung Active Watch.

 

It may not work for all but worth checking which app its asking to sync steps against. Even though I had disconnected fitbit, deleted myfitnesspal app from phone and reinstalled etc it was still trying to get steps from fitbit!!

 

You can check this by going into 'me' (bottom right), settings (cog icon top right), scroll down to steps under setting header. This will tell you with a tick where the app is trying to get steps from, I ticked samsung  health in there and everything synced correctly 😊

Highlighted
Also, make sure you go into settings/device maintenance and complete the analysis! Helped me out
Highlighted
New Member
I have managed to update my active 2 August update this morning 15/08/20. If you have been trying to update before and failed, you will probably find it will update now.
Top Liked Authors