Support

Open search

Left ear bud not working

Highlighted
First Poster

Hi my left ear bud stopped working all of the sudden wont connect or charge  wearables app show a i next to the left bud i have cleaned the connectors still nothing i have also tried using the correct cable that comes with them amd still nothing can anybody help

9 REPLIES 9
Highlighted
Moderator
Moderator
@Zgoatzop: Can you try placing your Galaxy Buds back in their case for 10-15 seconds, and close the lid. Reopen the case to enable Bluetooth pairing mode, and check the screen of your connected device. If this doesn't work, please make sure that you are within 10 metres of your phone to stay in range of the Bluetooth connection. I also recommend checking for an update on the Galaxy Wearables app by going to About Earbuds > Update Earbud Software > Download and Install, to see if this helps.



Highlighted

Hi it not redgesting that it in the case at all my right one works perfectly fine ive left them in the case for a full day to try charge it but nothing 

Highlighted

I also cant updated them because it isnt regesting that there is an earbud in the case 

Highlighted

Please check the magnetic connectors inside the case, are they damaged? If they are fine, can you place only the Galaxy Bud that is not working in the case? Does the case light red? If it still doesn't then your Galaxy Buds will need to be checked by an engineer for a repair. You can get in touch with the Samsung Technical Support via Twitter or Facebook to be assisted further with this: https://www.samsung.com/uk/support/contact/

Highlighted

Hi yes when i place the ear bud in it lights up red 

Highlighted

Which model phone do you have the Buds connected to?

Highlighted

Samsung galaxy a 9

Highlighted

Ive tried everything you said anf nothing. Although there is a update Im not able to install it due to the left earbud not connecting to my phone.

Highlighted

Im having the exact same problem as you.

Top Liked Authors