Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Latest update problem, watch will now not connect.

(Topic created on: 26/11/19 10:41)
Scottynjo
First Poster
Options
Wearables

Just brought a new samsung galaxy S2 watch for my wifes birthday, worked and connected fine until next day when she updated latest version of Galaxy wear, now watch is useless as won't connect through the app anymore, tried everything on the internet, resetting phone, watch, hard resets, uninstall app, etc, etc, still nothing pairing!!!😡 seems like everybody is having same issues. WHY IS SAMSUNG NOT HELPING? Just a way of making easy money by Samsung getting people to buy watch then making it inoperable? So frustrating! Watch works on my phone great but I haven't pressed the update so definitely seems like the app is causing the watch to be deemed useless!!!

0 Likes
Reply
1 REPLY 1
SaudA
Moderator
Moderator
Options
Wearables
Hi @Scottynjo

Looks like you've tried pretty much all the troubleshooting steps. As it seems to work with phones on different firmware, it's probably best if you can send an error logs through via the Members app. This way, our developers will be able to have a closer look.

To send this, follow these instructions: On the watch, make sure that Settings > About Gear > Report Diagnostics > Toggle On.
On your phone, launch ‘Galaxy Wearable App’ > More (3 dots) > Contact us > Error Reports > Input Symptoms > SEND.

Please do this within 15 minutes of your experiencing the issue.

0 Likes
Reply