Open search

Heart rate monitor issues with Gear fit 2 pro


I've been experiencing some issues with my gear fit 2 pro heart rate during exercices, especially inconsistency in heart rate monitor during "other workout". With gear fit 2 I had no problems, but since I upgraded, I haven't had a clear reading and I've been using my gear fit 2 pro for more than a month now.

For exemple (using Samsung health app), with gear fit 2 I would get peaks of 200 or more during exercice and now the peak I get is around 180. Also, during workout, sometimes the band vibrates as if not able to measure heart rate.  I also get a flat line  at 180, for exemple, of two or more minutes in the workout graph which I think is should not happen.

When I use the UA record app to record my session, my heart rate graph has some grey zones (as if not able to measure heart rate) and I also feel  band vibrat on my wrist. Someone with the same issues?!  Smiley Sad




Hi Anarita,


Thanks for letting us know.

There has been multiple reports of this already.


It's ridiculous that Samsung have not fixed it yet.

The galaxy watch even uses a different software version and a different HR monitor.


I'm aware of those reports. It's ridiculous to say the least...


I'll keep my gear fit 2 pro that sometimes works fine, sometimes doesn't and will not upgrade to the Galaxy watch.

I really enjoyed the new features of the new watch, such as the speaker and the automatic brightness, but will not upgrade for a watch the seems to have more trouble with the HR than this that I have. Very disappointed.


I am having the same issues after the update. I'll post in the other thread, but has there been any traction on this since September? I find it odd that it's been almost a year and Samsung hasn't offered a fix. 

Come on samsung, please fix this issue already. its been a year since people complaining abou this issue.

 Got this device as a gift.  Useless if I can't use the HR monitor. Will go back to useing my Fitbit. 


First Poster
I have the same problem!
First Poster

It's amazing that after exactly one year your post, Samsung hasn't sorted this issue out. It is very frustrating.


My Fit2 pro is a month old and is already giving me the same problem. It stops measuring at any given time. 

When it stops, I always try to reboot but sometimes rebooting doesn't help. 


I think the issue is with "Auto HR". This morning before my run, I wanted to get the device running before I start and I battled (no HR reading update). So I decided to switch from "Auto HR" to "Frequent". I then did a manual measurement of HR and successfully got a new reading. I switched back to "Auto HR". Only then it worked and I could start my run.


The second issue is the issue of incorrect HR reading. I had been sitting in front of my PC at work for about an hour. Gear Fit2 pro, on Auto HR, was reading between 135 - 137bpm but when I did a manual reading with my Note4 the reading 71bpm.



yap, it's really sad. I'm still using mine, but I'm very close to switch to a Garmin because I find it extremely frustrating all this HR thing.


Anyway, I've been having some good readings lately during gym/class workout using the UA Record app in the following exercise mode: activity, select gym and then circuit training. I don't get hr flat lines and as far as intensity, its seems similar to my older gear fit 2.


However, running is becoming even more frustrating. From time to time, I get those flat lines and lately I've been having issues with GPS. The distances aren't right and sometimes the GPS can't get location.  To solve this, I've disconnected gps in running and use my phone instead.... but the latter was supposed to be at home.... really sad with Samsung 😞

I'm late to this discussion but can confirm what many people have said:

1. If I start an exercise with "Auto" tracking, I get flatlines on occasion. If I do the same exercise the next day but start the exercise explicitly, I do not get flatlines.
2. If I take the Gear off and put it back on, it can take up to half an hour (!!!) for Auto HR to kick in again and start working. However, if I put the Gear back on, go to heart rate settings, tap Auto HR (it's already on, I just tap again), tap the confirmation "OK", the Gear then starts tracking HR again almost immediately.

Note that all my exercise is walking right now, although vigorous, i.e. I easily get up into the 150s with my walks/hikes.

Looking at continuous charts for sleep, the 1-hour charts do show flatlines but it is quite possible that my heart really does sit at, say, 55 beats for 5 minutes when I am in deep sleep so I would not call those errors per se. There are no flatlines of an hour or anything in my sleep HR charts.

So it's clearly a software bug as many have said, since I can reset proper HR simply by tapping Auto HR.

I really like the watch so I do hope they get this fixed.


I think you'll find you get the same result if you just tap Auto HR again. I do this if the Gear is "stuck" (not reading HR) and it works:


1. Go to HR settings

2. Tap "Auto HR" (you will have it already selected, just tap it again)

3. Confirm


Your Gear should now go back to Auto HR quickly (less than a minute).


Works for me. I wish it could be fixed, it's so obviously in the software.

Top Liked Authors