Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Gears S3 SM-R760 GPS not working

(Topic created on: 29/01/18 21:06)
Kurkoko
First Poster
Options
Wearables

I installed all samsung apps, updated.

Got my Gear S3 and I am only able to make work GPS 1 time, every time I perform a Factory reset and repair again.

All permissions a granted to Samgung Gear, Gear S plugin and Samsung service.

 

Tried, Yelp and HEREWego, even shealth to track a test.

On Gear S3 location is set to on (GPA+Wireless).

 

Sometime I see Gear S plugin running and locate me.

I find strange I need my smartphone to locate me, and even this rarely works.

 

Is frustrating.....

Android 6.0.1 Xiaomi Mi5

0 Likes
Reply
1 ACCEPTED SOLUTION
Solution
hespeet
Apprentice
Options
Wearables

I have the following experiences with GPS on my Gear S3. I've been supported by Samsung very well, and I used, amongst others, this forum and  this post to find out what my problem actually was. I want to share my experiences with others, so that they need not spend so much time on this
issue as I did.

 

My location determination was very erratic. Sometimes it worked, sometimes not, sometimes not well, sometimes not at the beginning of a walk, but then it worked well further under way. It drived me crazy, because I bought the S3 also for keeping track of my activities, and for that you need a good-working GPS.Now I couldn't rely on it.

 

First of all: there are two methods of getting a location for your S3:
     1) WITH a bluetooth connection with your phone, on which location services is switched 'on' and the Samsung Gear S app is opened (in the background is fine), and
     2) WITHOUT a bluetooth connection with your phone, stand-alone. With this, your S3's own GPS-module is needed to determine your location from its contact with GPS-satellites

 

When I started to understand this from the fora (I believe it was this post, actually), I performed several tests, with and without a bluetooth connection with my phone (and on the phone the location services switched on and the Gear S app active).

 

So it turned out when I had my phone with me, option 1), my positon was correct (say, +/- 10m, the GPS resolution) and my walks were registered corrrectly. So no problems with option 1). After my 'training' (walk), the summary also showed my route on a map (at the bottom of the log).

 

(for the bluetooth connection, the 'LE' (low energy) connection with the phone is enough. There's also a 'non-LE' bluetooth connection, but this one is for a larger bandwidth. You can have a telephone conversation with this connection through your S3. This broader-band connection is not necessary for general information exchange like GPS-coordinates or Whatsapp messages.)

 

(During all my testing, when I didn't fully understand how it worked yet, I noticed that the Gear S3 'knows' your general gait-length. With this, it is able to also measure your walking-distance by counting your steps. I recon the S3 needs a good 'learning-period' first with correct GPS-readings, in order to draw conclusions about your gait-length (GPS-measured distance, divided by the number of steps). I seem to remember that in the beginning, I measured wrong distances while walking. It might have been the case that I had no GPS-coordinates (probably no bluetooth connection with the phone and no GPS-reading from the S3 itself) and the S3 didn't have a good avarage gait-length for me yet. It consistently measured a shorter walking-distance that it actually was.)

 

After reading on the fora how the location services worked on the S3, with and without a bluetooth connection with my phone (iPhone 6S, by the way), I started testing option 2). I switched off the bluetooth connection with my phone by switching on the airplane mode (swipe down on the default watch-screen and tap the little airplane) and started a walking-training. For this case to work correctly, the S3 needed to receive the GPS-information on its own. That didn't work at all. Whatever I tried, I didn't get a GPS-reading. It kept 'determining position', without finding it. Often I got the message that location could't be found, please move to an open area' (or something similar), although I was outside, under a clear blue sky.

 

I also downloaded the 'Quick GPS position' app on the S3. An app to show you your latitude and longitue coordinates, and nothing more. With this app, it was clear that a GPS-reading was not possible. It kept saying 'aquiring postion...', but didn't find one.

 

My conclusion was that the GPS-module/function of the Gear S3 must be broken. So then I accepted the fact that I needed to walk the 'Samsung service route'. I called Samsung and after walking the 'support scripts', the conclusion was that the S3 needed a warranty repair. I got a web-link for reporting my faulty S3 and starting a service request. It was all Dutch, so it probably works differently in other countries, but just to show the link:

 

https://samsung.drmobile.nl/sam_nl/device/

 

I reported my S3, the faulty GPS, uploaded my receipt and started to wait for the all free pick-up-and-return-service to happen. From that moment on, I was kept informed perfectly about the status of the transports and repair of my S3. They came to pick it up on a Wednesday evening (small cost for me, but I didn't need to take a day off from work for that). The following Friday, the bell rang on 8:30am. And there it was, my own S3, with a repaired GPS ('board-swap', the receipt said).

 

After several test-walks without a bluetooth connection with my phone, my conclusion is that it works perfectly now. It registers my location, keeps track of my route, everything!

 

I hope I have helped other people by telling my story so that they can skip all the Internet-searching, uncertainties about how it should work and quickly draw the right conclusions about whether the Gear S3 needs a GPS-repair or not.

 

Good luck!

 

Peter

View solution in context

63 REPLIES 63
miglozoya
Apprentice
Options
Wearables

@GPSviews wrote:
I am sorry to hear that... I just shared my experience and I am lucky to say my Gear S3 is working just perfect. I work on remote areas where I have to trust my gear. I had great results even close to glaciers in Patagonia where other devices stop due to the cold environment. Perhaps the watch is helped by the temperature of the skin. The battery drains a lot faster on these conditions but it has been flawless after knowing these glitches. Some data looses accuracy due to fast changes on altitude (ATM pressure), like during flights on helicopter but that is expected. I use it on kayaks and rafting as well, with rocky canyons and deep forest on the sides without issues. So, I do not know why your device is not ding its magic. Justin case it helps, I use my watch with at least 220MB of RAM free (not storage). Perhaps with more apps, there is lesser RAM available for the processor to do its job.
I am sorry for not having further ideas to help you. Best wishes with it and if you find the issue, share i here.

Cool thanks! I have not even one single app installed, only those from stock so it shouldn't be an issue. Cheers!

0 Likes
Reply