Open search

Gears S3 SM-R760 GPS not working

First Poster

I installed all samsung apps, updated.

Got my Gear S3 and I am only able to make work GPS 1 time, every time I perform a Factory reset and repair again.

All permissions a granted to Samgung Gear, Gear S plugin and Samsung service.


Tried, Yelp and HEREWego, even shealth to track a test.

On Gear S3 location is set to on (GPA+Wireless).


Sometime I see Gear S plugin running and locate me.

I find strange I need my smartphone to locate me, and even this rarely works.


Is frustrating.....

Android 6.0.1 Xiaomi Mi5


Thanks for the feedback. After reading other fora and doing more tests, it is obvious to me that the culprit is the calculations being halted when the screen is not on. Explaination: Try runnign at a regular pace, then check your watch (turning your wrist) and then turn it back to running position and change your pace (even stop for a second). Now resume running and check your pace, and you will be amazed to see that it starts from almost 25'/km to read 25'/km -> 21'/km-> 13'/km->6'/km->then it starts stabilizing around the right pace. SO what I read from this is: when my watch screen is not "on" the calculation is bogus or inexistant.


Thank you, thank you, thank you. I was wondering why my GPS was working when I was out running, but not on my bike. Phone had power saving on and is in my bag when cycling - don't carry phone when running. Now I can stop pulling my hair out.

Good for you, but I'm not sure whether it has any relation with my previous. Anyways, if your watch is working fine now, happy to hear that. Wish I could say the same!

Kind regards,

Many thanks. Please on these cases it is always useful to have the firmware version since it seems that it may affect the GPS's performance. I just updated mine and now it takes 15 minutes fixing and it looses the position very easily.

Hi there,

I updated mine to Tizen 3.0 yesterday and it seems like the GPS is slightly (just slightly) better. I notice it still loses track every now and then, but specially if you are under trees (even iny ones) it simply sucks 😞


@BorisGroenhout wrote:

I have had the same problem with the GPS on my Samsung Gear S3 Frontier.

The GSP problem was caused by the Weather app. I went to the Gear S3 app on my iPhone, chose for Apps, Settings per App, Weather, set automatic refresh to every 6 hours and deselected the current location option. The Weather app on the Samsung Gear S3 now showed the message "Add currect location". Went back to the Gear S app on my iPhone and selected current location option again. In the Weather app on the Samsung Gear S3 now the current location was displayed. After that GPS functionality works fine in all the other Gear apps also. Problem seems to be solved. 

Thank you so much. I was just about to give up and then came across this post. Stupid Weather App. I did what you did and that's fixed the issue for me also.

I am using Tizen and my GPS is working very well. Even between high buildings or inside a forest.
So, I can tell the device is good and working well but it has some details to be known. One is to upgrade the firmware. Another side is the weather app as Tacheus just pointed out as being part of the problem. Another issue I found is the phone itself. If you have linked the phone and the watch, the watch uses the GPS of the phone (it saves energy that way) but I have found that on that case, if the phone is put inside a backpack or sometimes even in the pocket of my shirt, the watch looses tracking. Not because its GPS is faulty (in fact on this mode it is not even being used) but due to the phone's GPS. I is strange because the phone itself, tracks very well even despite being inside a backpack. But it is connected to the watch, and put inside something, the track tend to be way weaker. So for Miglozoya and others with GPS issues on their watches, I recommend testing it again but putting the phone on airplane mode or off to prevent it from linking with the watch and that way, forcing the watch to use its own GPS receiver. The latest firmware provided some changes and now when selecting some apps (walking, bike, trekking and others) the app shows on the top an icon blinking when the GPS is looking for its position (first fix may take a minute or two) and then it notifies when the location has been found and is ready to go. Mine is working perfectly well after knowing these issues.
If I want to use the Gear S3 with the phone outdoors (then using the phone's GPS), I have to properly expose the phone (out of pockets, deep inside backpacks etc) to be sure the track is fine. I got a nice metal phone holder for my bike and since then both are working very well; when kayaking I have the phone in a drybag on top of the hull; and while hiking I have the phone on the uppermost pocket of the backpack, away of the sunlight but just a thing layer separating it from the sky (satellites signal).
When using the Gear S3 without the phone, I wait for the watch to fix the location and then go. It does not loose the track but as expected, its battery drains faster than when using the phone's gps.
Kind regards!

Dear GPS Views,

Actually when I run with my watch I never-ever carry my phone with me. That was one of the main reasons why I bought it and also the source of my frustration. I am also on Tizen 3.0.1 and always wait to get the green location signal before hitting the start button for my runs, but even so, it is sooo inaccurate. I invite you to read the story and details of my headaches with the watch in the thread and you will understand. I normally run around 4:30/ 4:45 min/ Km (for some of you ~ 7:30 min/ mile) and it is constantly, steadly wrong (always higher) -except for some isolated moments of glory when it works fine. I also had the issue with the auto-pause feature, as when I started running after a traffic light (example) it took the beauty almost 1 km to catch GPS signal back...But please read my previous posts and you'll have an idea of my struggle 😞

Dear Miglozoya,
on that case I would not rule out a defective item. Perhaps if you have it still covered under warranty, you should try that way. With my own headaches I read so many posts and in more than one I found that the device was defective and after Support replaced the board, the watch was working just fine. I am just speculating here but noticing the date of these posts, it seems to me that this tended to be the case on earlier or first lots of these watches, and therefore more recent lots may have a different hardware.
Mine is a SM-R760 and the autopause is working like a charm. I just move on my bike a couple meters and it gets back on tracking. So there should not be a reason for yours to not do the same after taking care of all these "details" with the weather app, etc. I would try with the warranty since these are not cheap toys. It should work fine. Best luck to you

Hi again,

If you see my records, I repaired my 1st watched 3 times, then got a replacement from SAMSUNG, then sent the new one another 2 times, same errors. And I have been using it in different countries and different "running scenarios" so I honestly don't know what happens. I remember that for my 1st watch they replaced the mother board but experienced the same issues....I'm lost, really. Thanks for the interesting discussion!

Top Liked Authors