Open search

Gear S3 can't connect after Oreo update


Hi everybody,


after Oreo update (few weeks ago) I couldn't update any galaxy apps and Gear S3 got disconnected from phone. 

Today I got new Android update with which update problem of galaxy apps is fixed but connecting Gear is still not working...

I tried with clearing the cash from whole phone, from Gear app, deleting BT profile, installing Gear app from play store and galaxy apps...

Phone and watch get paired, percentage count get to 100%  but phone stays forever on screen "setting up your phone..." and "almost there" is just blinking...


Phone Details:

Samsung Galaxy S8

Model No: SM-G950F

Android Version: 8.0.0

Samsung Experience Version: 9.0


Gear S3 Details:

Samsung Gear S3 Frontier 

Model No: SM-R760

Tizen Version:


any idea how to fix it?



currently I'm in Serbia where phone was bought, watch was bought in Slovakia

Hello Guys,


I have no idea how it could happen, but since my last post I haven't used my gear at all, switched it off and left in the drawer, waiting for better times. Today, minutes ago, I started the watch, it was left as not configured, like from the factory. So after the welcome screen and picking up the language Gear tried to connect with my s7 and .... surprise surprise ... it paired the watch and allowed to configure the watch with the phone. So far I installed applications and watch faces ... and all works. I do not know, if there are any different issues but the first major issue gone. I have the watch and the phone succesfully paired. If you didn't try to connect it again, please try now ... maybe some 3rd party app, which was automatically updated on my phone 'unlocked' the pairing process? Good luck!


to me this is still not a solution... still stacked on "almost there" screen...


@LiamH, did you had maybe any progress in identifying problem? thanks

Hi @MilosDjuk


I'm unable to access your Error Report as you're outside the UK unfortunately. I've passed on the other user's Error Report internally. I'll post the results once I've received a response. 

I'd advise contacting your local Support Team for help with your indiviudal Error Report, or awaiting a response from their Customer Services via the Samsung Members app. 






Thanks for sending over the Error Report, it helped us resolve the issue. The response we received was that there was a temporary server issue when your device was trying to register. The problem was with the Gear app itself which has been fixed server side, hence it now working for you.


A simple restart of both devices will solve the problem if this occurs for anyone else within the UK. 

View solution in original post




Cool! @LiamH, thanks for letting us know waht was the root issue.





I got reply in samsung members app: restart gear and reinstall gear app

Not much of a help...


Hi Milos,


In my case, after galaxy s7 update to android 8.0 I had to reset the phone to factory settings as an update failed. Obviously all custom settings were wiped out, including configuration with my Gear S3 watch. Once the phone started working and I wanted to pair the phone and the watch together, the first step on the watch was to reset the watch to factory settings too. After that I could pair the phone and the watch together. As previosuly mentioned, it didn't happen at the first attepmt, as there was an issue on the Gear server site.




Yap, factory reset of phone did it's magic :smiling-face:

Hope I'll not have to do it with every android update...

Top Liked Authors