Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Galaxy Watch6 Classic 47mm LTE: randomly not showing incoming call notifications when connected to phone via Bluetooth

(Topic created on: 19-10-2023 09:56 AM)
512 Views
Christopher_K
First Poster
Options

My setup: GW6 Classic LTE (eSIM activated) paired with a Samsung Galaxy S10+ - both running on latest available software.

Watch settings: Bluetooth: always on, WiFi: automatic, Data plan: automatic, DND + Sleep Mode + Theatre mode: disabled and not set to sync with the phone

The problem: When the watch is connected to the phone via Bluetooth (ie. data plan on watch is not active), it receives incoming call notification from the phone only up to a specific point. After a random amount of time (can be an hour, can be a day) the incoming call notifications just stop coming in - there is no pattern to it, it happens even if both the phone and the watch just lay next to each other for some time without using any apps. There are no visible errors or app crashes happening either.
Once this problem occurs, If I miss the call or decline it on the phone, I can still see it in the list of missed calls on the watch popping up immediately. Also, when I answer the call on the phone, I can see the green phone icon on the watch face and can tap on it just fine, so it's definitely not a pairing issue per-se. I can also make the calls from the watch, it's just the incoming ones that are not showing up which can become really frustrating at times. I checked if by any chance a remote connection to phone is triggered in these instances but no - it all goes directly through BT.

Even when no incoming call notifications are coming in over Bluetooth, other notifications work just fine and Galaxy Wearable also lets me change/see the watch settings. If I explicitly disable Bluetooth and use the data plan on the watch at all times, everything works as expected, however I'd like to keep it in the automatic mode to save battery (and also not have the watch vibrating on my desk when a call is coming in and I'm not wearing the watch, since that's missing the point a bit).

This is very likely NOT an issue with setting the right permissions or notifications, since one thing that randomly helps is restarting the watch or disabling and re-enabling Bluetooth. However, this doesn't always work, so it's really difficult to tell what the actual cause of the problem is. 

I tried going through all the regular troubleshooting listed here, including resetting the phone, following steps in: https://www.samsung.com/us/support/troubleshooting/TSG01003245/ and also making sure all notifications are properly set and permissions are not changed - to no success, so it seems like either a software bug or some weird power-saving feature that enables itself after a while (but I have no idea what that could be).

Any idea on what might be causing this (or if it's even a known issue at Samsung) would be very welcome, as this is really impacting my user experience and limits the watch's usability a bit.

0 Likes
2 REPLIES 2
Christopher_K
First Poster
Options

One thing I only now just noticed is that if I make the call from the watch then the phone also opens up the phone app as expected, so it seems like connection watch -> phone is working fine but phone -> watch is somewhat broken? 

0 Likes
Blessed4life
Black Belt 
Options
That's correct, but if you turn off your phone and make a call on your watch it works how it should, (note) if your data is on auto the watch will ask for permission to make the call.
0 Likes