Support

Open search

Galaxy Watch3 with Buds Live.

Highlighted
Apprentice
Good day,
Just wondering if any techs on site can assist with this problem.

Equipment:
Galaxy S20 Ultra, Galaxy watch 3 non LTE version paired with the new Samsung Buds Live. All software up to date.


When using Buds and playing from Galaxy S20 Ultra via Spotify no issues at all.  Excellent sound quality and no connection issues at all.


When playing music from watch via Spotify no issue at all when stood still


As soon as I start running the connection becomes unstable and both running coach and Spotify music become intermittent to an extent that it is unusable. As soon as i put my hand over the watch to steady the motion, the connection seems to get slightly better. But its impossible to run not swinging arms.
The watch is fixed firmly round my wrist with silicon strap. I am running on UK country lanes so there is no equipment around to interfere with signal /connection.


S20 Ultra is left at home.
Spotify app is standalone and offline. Playlist is downloaded and saved to watch.


I also have connected both the new Pixel Buds 2 and Apple Powerbeats Pro. Both have connected to GW3 no problem, however the volume on both devices is incredibly low. The volume is low to a point that its almost impossible to hear music over traffic. 


I have checked system settings on all devices and in Spotify app and set volume to max. This has not fixed the volume problem.


I had no issues with my Watch active 1 using Apple Powerbeats Pro with the same set up as described above.
Can any tech bods advise please.

Thanks.

6 REPLIES 6
Highlighted
Apprentice
*UPDATE*
Seems like installing/activating Bixby on GW3 has solved the volume issues with the Pixel Buds and Powerbeats Pro.
I will keep you updated on the Buds intermittent issue.
Highlighted
First Poster

I have the same problem

Highlighted
Sorry to hear your having the same issue.
I have been using the new Pixel Buds on my runs along with GW3 utilising Spotify watch app and have had no problem. Volume and next song taps are working fine. Apple Powerbeats were intermittent and I still have the same problem as described above with the new Galaxy Buds which is a shame. As soon as I find a fix I will update.
Highlighted
Apprentice

Facong the same issue

Highlighted
Apprentice

Facing the same issue

Highlighted
I've gone back to using an old iPhone x with Powerbeats Pro for my running as the Spotify app on GW3 has been nothing but trouble. Pixel buds started disconnecting too. Pity as Samsung has so much promise with the new GW3 and buds live.
Top Liked Authors