Open search

Galaxy Watch Stops Recording work out part way through


So this is really annoying now.  For months the watch has been fine but a couple of weeks ago now I got half way through a run and the watch stopped recording.  I use the watches work out app, select running (basic work out) and press start.  It records for about 10 minutes and then stops.   So a couple of days ago I set the screen to stary on during the run and it was fine for one run.  I ran again today and again it stoped after about 2km; no record of the run at all.  Any help would be greatly appreciated.

188 REPLIES 188
That's so good to hear. Thank you for pursuing that and letting all of us know!

I've been having the exact same problem - beyond annoying.

Yes, same problem while cycling.

I think this may be a bigger issue than just Samsung Health.  Occasionally my watch appears to be unresponsive for a few seconds.  Just a black screen.  Might be why Samsung Health quits.

Ha, glad I'm not the only one - I thought it was just me, or at least I thought it was related to the Samsung Health issue.


I've now paid for 'Gear Tracker' from the Samsung Watch App store, which is supposed to be fantastic, very responsive dev and all the advice online seems to be that it's miles better than Samsung Health.


Tried to track a run with MapMyRun last night and although it worked, syncing to Strava was a nightmare and also the UI of the app whilst tracking has a lot of very small fonts that are hard to read when moving!

Not sure if this makes a difference but my last 4 or 5 workouts have recorded perfectly and the only thing i've done differently is not skip the 3 second countdown at the start! May be just luck though

First Poster

I'm having the same issue, started about a week ago, its stopped recording my run 3 different times now.

Also having trouble with spotify playing offline and stopping playing halfway through a run.

My last five workouts (hiking for multiple hours each) recorded successfully without stopping.

The only thing I've changed: I waited for the GPS and heart rate signal, before starting the workout.

Auto-pause is turned off. I paused the workout manually several times during the workouts.

First Poster

Hi All,


Since a couple of weeks (3 or 4) I have (had) these experiences, exactly as described in the initial message or in the different further replies. First I thought it's an incident (restart the phone, etc.). Last 2 weeks I experienced it as an structural issue with a lot of frustration and doubts about the Galaxy Watch stability. So one week ago I serched and found this topic. 


About my settings:

> I have the Galaxy Watch 2 46mm

> Auto workout detection is turned on.

> Auto-pause is turned on.

> I use the following trainings registrations: Running - 2 times a week; Cycling - once/twice a week; Hiking (phone in my pocket) - almost daily

> Sometimes I wait on the GPS and Heart rate; By the walking training I don't do that.

> I've installed some additional apps (3 or 4 - not much), but I like to install the most beautifull free watch interfaces which are promoted by the Samsung environment.


Last Thursday - Ascension Day - I was really frustrated after a week with automatic stops during the different work out(s) and thought maybe it has something to do with the installations of watch interfaces I've done in the few past. So I went really rough through the telephone and deleted al lot of them. I didn't do any other setting change in my phone or on my watch.


Now almost a week further, without any issue/automatic stop, I think it worked, so I want to share this with you all.


Probably a couple or all of you also have one or more of these Watch user interfaces installed, which maybe raises this issue, and use them.
Please check the screenshots of the user interfaces I've installed (and already deleted) in the last period when the issue raises on my phone. Big (second) screensshot shows all apps (watch user interfaces) which I've installed (or had installed in the past). I don't know if you can see  this picture good enough


Hopefully we come together to a solution for this annoying issue.

20200526_124912.jpgScreenshot_20200526-124321_Galaxy Store.jpg

Latest updates fixed the issue with my watch. Updated and tested this morning.

Top Liked Authors