Open search

Galaxy Watch sensors stopped working


Suddenly, all the sensors of my Galaxy Watch stopped working. I can not get heart rate readings anymore, or step counts or anything. It does not seem to be a hardware problem, considering that the heart sensor and the gyroscope stopped working at the same time, must be some kind of software issue.


I already tried:

- Rebooting (3x)

- Force rebooting (3x)

- Restoring factory settings (3x)


None of them worked.


Are there any workarounds for that issue? Is there a chance to get a software patch or anything? I tried to update the firmware, but Galaxy Wearable says that I already have the newest version.



My comment has been removed......


Figured it out. It is the barometer app, that is not well tested and doesn't work with OneUI update that came.


It all started with OneUI update which broke barometer app. It started showing negative altitude and as effect sHealth started counting floors like crazy. This is when I tried to update sHealth and another Samsung bug came up and confused me:


Next I tried to manually calibrate baro app, this of course didn't help at all and additionally this sensor thing happened for the 1st time. Next as I wrote few posts up, I turned the watch into watch only mode and after 2 days thins began to work again. Still baro was not working but I was happy that rest works and baro did not bother me.


After few runs I figured out that I'm missing elevation data in sHeatlh training monitor. So yesterday I tried to calibrate baro app one more time and everything went to ***** again. And then awe came.


I tried to stop barometer app, disable it and remove the widget. This did not help. I uninstalled it. It did not help. I restarted the watch and turned it into watch only mode with uninstalled baro. In the morning I activated all options and after a while every sensor (except baro -> altitude, floors) is working.


I'm not installing this baro app until some real fixing is done.

Now I'm without barometer app, I don't have elevation registered while training and floors are constantly 0 but I have pulse, steps, cadency, speed, GPS tracking, time measurement - essentials for which I bought this watch.

I can live wihout baro... at least for some time but I also bought this watch for this feature...


Can some confirm that this is the situation here and removing baro app and restating watch via watch only mode brings everything else back to life?


Samsung, however it's working now without air pressure, elevation and floors measurement I expect that in a watch for a *****load of money EVERYTHING will work as promised. As well as the Samsung Health update.

Now that I did your QA job, maybe you will open the codebase for me and I will do your DEV job and find the bug and fix it? I will do it pro bono, because if you can't get your job done, then who? I just want my f***g watch work the way it was specified in the prospects. You took my money promising this!


Hi all, has the problem disappeared for you all?

My watch after last update that fixed Samsung Health update bug:

started to randomly disable and enable the sensors. I'm so tired with this...

Has anybody got any clue?


Not really. Mine were disabled for weeks, came back for a day, gone for a week.

Now they have been back pretty good for the last few weeks, only disabled a couple days. No clue what is going on. The only thing I was doing was rebooting trying to get back.

I'm going for my fourht RMA today. Mainboard changed 3 (three) times and still the same problem. I will return this junk and ask for refund. I'm completely done with samsung devices, period.

The last few days the sensors have been working, I did nothing to fix it. Sometimes it will disable, but mostly working. Now my battery is draining overnight, lost 20% while sleeping, because of Samsung Health.


Same battery drowning issue with sHealth too

Last friday 05-7-2019 i received the watch from the repair service. They replaced MoBo and back casing with pulse sensor. So far so good, everything works. Hope it stays this way because I read there were guys who had had their watch repaired 4 times now.

I'm having the same problem and cannot solve it.  Sensors not working, SHealth not working consistently, received steps to get a debug log to them for the unexplained battery drain at night and cannot find where to access it to send it into Samsung (their instructions state to use a cable to connect to a PC however the watch is a wireless charge and the watch didn't offer me a way to save it to SD either).  Cannot find a way to clear SHealth cache on watch (since it seems to a problem on the watch not on the phone).  


So beyond frustrated with this as I watch to use the Watch for my SHealth stuff too and cannot do that with these issues.  Then the unexplained battery drain that happens.


I've disconnected from the phone and network and have done a reset on my watch several times over the past 2 days to no avail.  I also noticed that it's been users that have replied.  Where anything from Samsung support?  Other than the direct email that didn't address all concerns.


Hi, all my sensors where not working too. It started wirh the Hydrometer.

Next Day after i tried to kalibrate all sensors stopped working.

I did exactly what you recommended.

Deinstall Hydrometer. Watch Only. After i restarted all sensors except Hydro working again. Thanks a lot for your advice. Aad that Samsung is not able to fix that. I will not use the Hydro App anymore, it kills all sensors. For all whobhave same issue. It works like this and it is reproducable. Good Job. 


Top Liked Authors