Support

Open search

Galaxy Watch - screen wake up/turn off behaviour is irritating

Highlighted
Navigator

I got my Galaxy Watch on Friday and for the most part I love it. However, a couple of things really bug me about a) the consistency of the wake up gesture and b) its tendency to turn the screen off much more quickly than it should.

 

So for a) - sometimes I just find that the wake up gesture doesn't work at all and I have to put my arm down and then back up again until it works. This feature is one of the most fundamental aspects of a smart watch that needs to work. It is especially noticable if I'm lying down but occasionally causes issues when sitting or standing. I think it's something your engineers really need to look at as, after a quick Google, I've seen many people complain about it on the Gear S3. I hope this is looked into as the fact it was an issue back then but still hasn't been fixed is a bit of a bad sign to me...

 

For b) I have 2 main issues. 1 is that the screen timeout setting only applies if the watch was woken up by the buttons and not by the wake up gesture. I think it's fine to have a different screen timeout if it was woken by gesture, but it should really be a configurable option.

 

The other annoyance is that the screen turns off when you tilt the watch back down. I think this is OK if you've woken the watch up with a gesture but it should be possible to disable this if the watch has been woken up by buttons or the dial. 

108 REPLIES 108
Highlighted

Dude the screen being on is the largest draining of battery in every single computer there is just about everywhere in the world unless you're talking about supercomputers crunching quantum simulations. The screen is something that a computer totally doesn't need at all to do its job yet needs to dedicate power to so you as a human being can see the results of the computer's calculations.

 

It's also what heats up a lot of phones and computers which isn't good next to the computer processor.

 

Highlighted
New Member

I am alive worked for me 

Highlighted

I have found that not all watch faces are compatible with gthe "always on" function. I tried different faces and found a couple that do work. I hope this helps.

Highlighted
New Member

If you turn "good night mode" off, the watch should "open" when movement is sensed from your arm/wrist.

Highlighted

I had the same problem with mine. Tried everything suggested in this forum but nothing worked for any length of time. I finally took my watch back to Bestbuy for a refund. I also believe that SAMSUNG is aware of this problem.

Highlighted

The closest experience to keeping the face lit is to turn off the wake up gesture and setting the display timeout to a period longer than a few seconds. I am going to try eliminating the double tap to awaken to see if it will wake up with the arm movement.  

Highlighted

I actually find that it works great. What happens is, if you use the wake up gesture just to look at your watch at a glance, then it will time out after 5 seconds because it assumes you just want to check the time quickly. However, if you interact with the watch in any way (pushing buttons, menus, etc.), then the screen timeout is activated for 10, 15, 30 seconds or whatever you have it set to.

 

Highlighted

The problem is that, when you use the wake up gesture but you want use it more that  "to see the time", it will turn off after 6 seconds... that's annoying

Highlighted
Apprentice

The (I am alive) app works to negate this timeout. But only works with a few watch faces. One of them is the BORA_BLACK_FACTORY watch face. I leave mine on this face all the time and don't have any timeout problems.

Top Liked Authors