Support

Open search

Galaxy Watch 46mm 4G won't auto reconnect to phone via BT with 4G active

Highlighted
SOLVED
Explorer

I have a very annoying issue with my Galaxy Watch 46mm 4G after the last smartwatch software update a few weeks ago. The smartwatch just won't reconnect to my phone via BT once it's switched to 4G.

I have an eSIM loaded to my smartwatch for standalone with Orange and it all worked fine till the last major smartwatch software update a few weeks ago. When I'm away from my phone the smartwatch switches to 4G but then when I have my phone back with me the Galaxy Watch just won't reconnect via BT and it'll stay on Standalone mode forever. The only way to reconnect it back to the phone is to disable 4G and then to manually reconnect it to the phone via BT. There's even more. You have to toggle the BT switch on and off both on the smartwatch and the phone several times for the devices to reconnect which sometimes takes ages and it's extremely frustrating. 

You can enable the 4G back once the smartwatch is reconnected to the phone via BT but once it gets disconnected again you'll have to go through the nightmare of the manual reconnecting process again.

I also noticed the smartwatch doesn't get remotely connected to my phone while I'm on 4G which is needed to receive notification from your phone. It will just stay on Standalone mode with 4G.

There's something terribly wrong with the latest software update and I don't know how to solve this.

I contacted Samsung Customer Service and the only suggestion they were able to give me was to reset the Galaxy Watch to factory settings which I did twice, but it only worked properly till the moment the smartwatch switched to 4G but then I could not reconnect via BT while 4G was still active.

Is anyone having a similar issue? I'm seriously considering disabling 4G for good as there's just no use for it.

 

UPDATE: 

I noticed a strange behaviour related to the issue I described above. When I was out wearing my Galaxy Watch and without my phone with me, I activated 4G just to test if I could connect to my phone remotely. The watch didn't connect to the phone straight away and it was still in Standalone mode. Then I made a call from my watch through 4G and suddenly the watch got remotely connected to my phone. I could receive all the notifications from my phone via 4G.

Then I deactivated 4G again because I knew I would not get it connected back via BT when I have my phone with me. This was a bit tricky because it's not easy to disable 4G on Galaxy Watch 4G. There's some strange "processing" going on on the watch for a while and then you get prompted to "Connect to the same network as your phone" and you have to confirm it. Then you have to go to network settings again and only then can you disable 4G again. This is pretty cumbersome and time-consuming but eventually, you get there. Once 4G is disabled the watch connects to the phone immediately. I'm not sure if it's the way things should work because I think the watch should switch automatically to 4G and BT, but apparently, it's the only workaround for the connectivity issue.

 

UPDATE 29/05/2019:

The last update to One UI a week ago seemed to have solved the connectivity issue on my device (Galaxy Watch 4G 42mm). It now works as it should i.e. the watch switches and connects automatically to 4G or BT depending on what's available. Try updating to One UI and see if it works for you if you have the same issue too.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
The last update to One UI a week ago seemed to have solved the connectivity issue on my device (Galaxy Watch 4G 42mm). It now works as it should i.e. the watch switches and connects automatically to 4G or BT depending on what's available. Try updating to One UI and see if it works for you.

View solution in original post

6 REPLIES 6
Highlighted
Apprentice

Facing kind of same issue, I tried finding solution on XDA-OT forum but sadly no one had spoken about it. I guess we have to wait till next software update. 😞

 

Regards,

Larko Vupse

Highlighted

This is definitely a software issue because before the last update everything worked just fine for me. I wish someone from Samsung read my comments and gave this issue a little bit more of importance. So far the only "solution" they gave me was to reset the smartwatch to factory settings which didn't work at all.

Highlighted

I have exactly the same problem. 

 

Highlighted

The last update to One UI a week ago seemed to have solved the connectivity issue on my device (Galaxy Watch 4G 42mm). It now works as it should i.e. the watch switches and connects automatically to 4G or BT depending on what's available. Try updating to One UI and see if it works for you too.

Highlighted
The last update to One UI a week ago seemed to have solved the connectivity issue on my device (Galaxy Watch 4G 42mm). It now works as it should i.e. the watch switches and connects automatically to 4G or BT depending on what's available. Try updating to One UI and see if it works for you.

View solution in original post

Highlighted
Observer

I have a similar problem, allthough I don't have 4G on my watch.

 

Love the watch, but it will not reconnect with my Nokia 6.1+; it works perfectly when connected but once you move out of bluetooth-range, it goes to stand-alone (as expected) but when I move back into range it doesn't reconnect.

 

I've already tried the usual (clear cache, use 3rd party app, reset and go again, etc. etc.) but the only way to reconnect is to go to bluetooth on phone, forget the watch, start Galaxy Wear and pair manually.

 

I don't think it's a bluetooth-issue, because the watch DOES reconnect with the phone (it shows up in "bluetooth devices" as being connected), it's just disconnected from the Galaxy Watch plugin which it needs to work with Wear.

 

I've been checking out a lot of forums, but have found no solution so far. I suspect somehow the Galaxy Watch plugin somehow doesn't work properly with the bluetooth-autoreconnect function in Android 10.

 

I hope someone has some brilliant idea or knowledge of some upcoming update solving this, because this is annoying.

Top Liked Authors