Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Galaxy watch 3 LTE not making calls

(Topic created on: 16-09-2021 01:40 PM)
Joojooz
Explorer
Options
Wearables

Galaxy watch 3 LTE paired with S10

Set up mobile plan with O2, watch has separate number. Cannot make/receive calls without phone. Says 'connect using Bluetooth'. When someone tries to ring watch number, says ' person not available try later'. O2 are trying to solve it but no joy.  Help 🥺 please

 

0 Likes
10 REPLIES 10
AndrewL
Moderator
Moderator
Options
Wearables

@Joojooz: If you haven't done so already, please download the Galaxy Wearables app from the Google Play Store, and run through the connection process. Select your Galaxy Watch, select it again, check to see that the number code on the Wearables app matches the watch, and tap connect. From here, you will need to allow permissions for the app, and check the terms and conditions. Once you've done this, tap 'Agree', 'Agree to all' or 'Next'. Follow the on screen instructions to finish pairing the devices. Now, on the Galaxy Wearables app, go to Mobile Networks to scan for an eligible network, and follow the prompts to complete the activation. Let me know how you get on. 

0 Likes
Joojooz
Explorer
Options
Wearables

That's all been done. Esim set up, data plan enabled.

0 Likes
AndrewL
Moderator
Moderator
Options
Wearables

@Joojooz: While the watch isn't connected to your phone, can you try heading to Settings > Connections > Mobile Networks > Turn On Now. Alternatively, connect to your phone via Bluetooth, then set this to 'Auto' to see if this helps. 

0 Likes
Joojooz
Explorer
Options
Wearables

Already tried that, thanks for helping though

0 Likes
Trottsky
Helping Hand
Options
Wearables
I believe with O2 you need call and text on other devices turned on have you enabled it?
0 Likes
Joojooz
Explorer
Options
Wearables

Yes that is enabled

0 Likes
Ambieroo
First Poster
Options
Wearables
I'm on thr phone now to o2 trying to sort this had the watch since April and nothing is connecting
0 Likes
Joojooz
Explorer
Options
Wearables

Changed a few settings with O2 yesterday, very helpful but watch still in standalone mode let me know how you get on, thanks

 

0 Likes
Joojooz
Explorer
Options
Wearables

Have noticed in wearable app, remote connection, it says text, email, notifications, but not phone calls. Any help out there, thanks

0 Likes