Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Galaxy Buds2 weird buzz sound in right earbud

(Topic created on: 14-02-2023 06:14 PM)
3218 Views
anao
Journeyman
Options

Hi everyone!

So I just got my fresh pair of earbuds2, but unfortunately I think sth is wrong with one othem, whenever I try listening to anything in active noise cancelling mode or in ambient sound mode I keep hearing this weird buzzing sound in the right one. I can still hear it even when no media is playing. But that sound is magically gone when I switch off any noise controls. I have no idea if that's a normal thing or some kinda bug.... and it would be a total loss if I couldn't even use them fully with all of their features.

I've tried resetting and unpairing my buds but none of it worked. Can anyone please tell me is there sth else I could do? Or should I try return them? Thanks in advance!

0 Likes
8 REPLIES 8
Options
Firstly, I would remove the bee from your ear.. if there is no bee, I would return the buds immediately for a replacement set. I've the Earbuds Pro set and the noise cancelling is absolutely amazing!!
0 Likes
anao
Journeyman
Options

I think with a bee in my ear I would be in no shape registering any problems 🤣🤣🤣  maybe more accurate description for that sound is when your radio loses connection but not as aggressive 😉 so you think the only option is to return it to the retailer? 

0 Likes
Options
Absolutely....
0 Likes
Options
Unless you have got them wet, then stick the affected one in a cup of rice for a couple of hours/overnight to see if it dries it out...
0 Likes
anao
Journeyman
Options

They freshly new, the buzzing noise was there from the moment I took them out of a box, and unless they got into water  during production process I don't think that's the case... srsly no one else has the same problem?

0 Likes
Shelley123
Voyager
Options
That doesn't sound right to me, I would return them,
0 Likes
AB28
First Poster
Options

hi i have thie weird problem with my buds 2 aswell for the left bud and the first time i resetted the buds it was fixed but then after a while it was back again and the sound of my left bud was at 10 percent volume while the other right one was normal at 100 percent sound have you found a solution without sending it back?

0 Likes
morley19
First Poster
Options
I have this issue also did you find a fix for it?
0 Likes