Support

Open search

Galaxy active 2 accidental long press

Highlighted
First Poster

Recently got the active 2, and while great, there's one particular issue that I've been finding quite annoying. Whenever I have my arms crossed, my right arm (watch is on left wrist) accidentally ends up doing a long press on the screen which enters the watch face selection screen. I constantly have to hit the button to exit this mode and get back to the home screen.

 

Anyone have a fix for this?

11 REPLIES 11
Highlighted
First Poster
I need an answer for this, too. It's super frustrating.
Highlighted
First Poster

I have this same issue! I don't want to turn off the gesture, but I think I may have to if there's no other workaround.

Highlighted
New Member

Please fix this issue...the "accidental long press" happens at least 5-10x/day!  Maybe I am an overabundant arm-crosser, but this seems like a viable fix from the development end.

Highlighted
First Poster

Add me to the list of people having this problem and looking for a solution.....how do I turn it off?

Highlighted
First Poster

I have exactly the same problem. Really annoying. Please fix.

 

Highlighted

Me too, every time I fold my arms Longpress on the watch face happens. How to disable this function? 

Highlighted
Apprentice

Me too. I'm using the water lock, but it disables wake-up gestures too.

Helpppppppp 

Highlighted
Apprentice

Just found "Screen Block 2" on Samsung app store. Cross fingers

Highlighted
First Poster

I turned off the "touch wake-up" option in advanced settings and it seems to greatly reduce the amount of times this happens to me.  However, it does still happen from time to time since I keep the "gesture wake-up" on, but not to the point it annoys me like before

Top Liked Authors